modified on 1 lip 2010 at 11:10 ••• 45 701 views

Adresy IP oraz ARP

Z MikroTik Wiki

Spis treści

Opis ogólny

Wprowadzenie

Poniższy przewodnik traktuje o zarządzaniu adresami IP i ustawieniach protokołu ARP. Adresy IP służą identyfikacji podczas komunikacji z innymi urządzeniami sieciowymi poprzez protokół TCP/IP wersji 4. Komunikacja między urządzeniami wewnątrz fizycznej sieci przebiega za pomocą Address Resolution Protocol oraz adresów ARP.

Specyfikacja

Pakiety wymagane: system

Wymagana licencja: Level1

Poziom menu: /ip address, /ip arp

Standardy i Technologie: IPv4, ARP

Wykorzystanie sprzętu: -

Adresowanie IP

Poziom menu: /ip address

Opis

Adresy IP służą identyfikacji hostów w sieciach IP. Typowy (IPv4) adres składa się z czterech oktetów. Dla poprawnej adresacji router potrzebuje wartość maski sieci, tj. który razem z bitami pełnego adresu IP odwołuje się do adresu hosta, i który odnosi się do adresu sieci. Wartość adresu sieci obliczona jest przy pomocy operacji binarnego dodawania (AND) maski sieci i wartości adresu IP. Jest możliwe podanie adresu IP razem z ilością bitów adresu sieci rozdzielenie slashem "/".

W większości przypadków wystarczy podać adres, maskę sieci i argumenty interfejsu. Prefix sieci i adres rozgłoszeniowy (broadcast) obliczane są automatycznie.

Możliwe jest dodanie wielu adresów IP do interfejsu lub zostawienie go bez żadnych przydzielonych adresów. W przypadku połaczenia mostowego lub połączenia PPPoE, interfejs fizyczny może mieć przydzielony adres oraz być użytkowalny. Przydzielenie adresu IP interfejsowi fizycznemu zawartemu w moście oznacza zawarcie interfejsu w moście. Możesz użyć polecenia /ip address print detail w celu sprawdzenia który adres przydzielony jest do którego interfejsu.

MikroTik RouterOS posiada poniższe typy adresacji:

  • Statyczny - ręcznie przydzielony przez użytkownika do interfejsu
  • Dynamiczny - przydzielony automatycznie do interfejsu przez DHCP lub ustanowione połączenie PPP.

Nazewnictwo

actual-interface (read-only: name) - nazwa aktualnego interfejsu. Dla przykładu, jeżeli fizyczny interfejs, do którego przydzieliłeś adres, zawarty jest w połączeniu mostkowym, aktualny interfejs pokaże ten mostek.

address (IP address) - adres IP

broadcast (IP adress; default:255.255.255.255) - rozgłoszeniowy adres IP, obliczony z adresu IP i maski sieci

disabled (yes | no, default:no) - określa czy adres jest wyłączony czy nie

interface (name) - nazwa interfejsu, do którego przydzielony jest adres IP

netmask (IP address; default:0.0.0.0) - ogranicza część adresu sieci od części adresu hosta

network (IP address; default:0.0.0.0) - adres IP sieci. Dla łączy point-to-point powinny być adresami drugiego końca.

Uwagi

Nie możesz mieć dwóch różnych adresów IP z tej samej sieci przyznanych routerowi. Exempli gratia, kombinacja adresów IP 10.0.0.1/24 na interfejsie ether1 i adresu IP 10.0.0.132/24 na interfejsie ether2 jest niepoprawna (chyba że obydwa interfejsy mają między sobą połączenie mostkowe), ponieważ obydwa adresy należą do tej samej sieci 10.0.0.0/24. Używaj adresów z różnych sieci na różnych interfejsach.

Przykład

[admin@MikroTik] ip address> add address=10.10.10.1/24 interface=ether2
[admin@MikroTik] ip address> print
Flags: X - disabled, I - invalid, D - dynamic
  #   ADDRESS            NETWORK         BROADCAST       INTERFACE
  0   2.2.2.1/24         2.2.2.0         2.2.2.255       ether2
  1   10.5.7.244/24      10.5.7.0        10.5.7.255      ether1
  2   10.10.10.1/24      10.10.10.0      10.10.10.255    ether2
[admin@MikroTik] ip address>

Address Resolution Protocol

Poziom menu: /ip arp

Opis

Nawet jeżeli pakiety IP adresowane są poprzez adresy IP, adresy sieciowe muszą być używane do faktycznej transmisji danych pomiędzy hostami. Address Resolution Protocol używany jest do mapowania adresów IP poziomu 3 modelu OSI do adresów MAC poziomu 2 modelu OSI. Router posiada tablicę aktualnych wpisów ARP. Normalnie tablica jest budowana automatycznie, ale w celu zwiększenia bezpieczeństwa sieci, może być częściowo lub całkowicie stworzona statycznie poprzez dodawanie statycznych wpisów.

Nazewnictwo

address (IP address) - mapowany adres IP

interface (name) - nazwa interfejsu do którego przydzielony jest adres IP

mac-address (MAC address; default: 00:00:00:00:00:00) - adres MAC do którego mapowany jest adres IP

Uwagi

Maksymalna ilość wpisów ARP wynosi 8192.

Jeżeli opcja ARP jest wyłączona dla danego interfejsu, np. ustawiona jest wartość arp=disabled, ARP powoduje, że router nie odpowiada na żądania wysyłane od klientów. Ponadto, statyczny wpis ARP powinien być dodany również u klientów. Dla przykładu, adres IP i MAC routera powinien być dodany do stacji roboczych Windows przy użyciu polecenia arp:

C:\> arp -s 10.5.8.254  00-aa-00-62-c6-09

Jeżeli arp jest ustawiony wyłącznie na odpowiadanie (reply-only) w ustawieniach interfejsu, router będzie wyłącznie odpowiadał na zapytania ARP. Adresy MAC sąsiadów będą ustalane statycznie przy użyciu /ip arp, ale nie będzie potrzeby dodawać adresów MAC routera do tablic ARP innych hostów.

Przykład

[admin@MikroTik] ip arp> add address=10.10.10.10 interface=ether2 mac-address=06 \
\... :21:00:56:00:12
[admin@MikroTik] ip arp> print
Flags: X - disabled, I - invalid, H - DHCP, D - dynamic
  #   ADDRESS         MAC-ADDRESS       INTERFACE
  0 D 2.2.2.2         00:30:4F:1B:B3:D9 ether2
  1 D 10.5.7.242      00:A0:24:9D:52:A4 ether1
  2   10.10.10.10     06:21:00:56:00:12 ether2
[admin@MikroTik] ip arp>

Jeżeli statyczne wpisy ARP używane są w celu zwiększenia bezpieczeństwa sieci, powinieneś ustawić arp na interfejsie wyłącznie na odpowiadanie (reply-only). Zrób to w stosownym menu w /interface:

[admin@MikroTik] ip arp> /interface ethernet set ether2 arp=reply-only
[admin@MikroTik] ip arp> print
Flags: X - disabled, I - invalid, H - DHCP, D - dynamic
  #   ADDRESS         MAC-ADDRESS       INTERFACE
  0 D 10.5.7.242      00:A0:24:9D:52:A4 ether1
  1   10.10.10.10     06:21:00:56:00:12 ether2

[admin@MikroTik] ip arp>

Usługa Proxy-ARP

Opis

Router z poprawnie skonfigurowaną usługą proxy ARP zachowuje się jak przezroczyste proxy ARP pomiędzy bezpośrednio połączonymi sieciami. Rozważ poniższy diagram:

Grafika:proxy-arp-1.jpg

Załóżmy, że host A chce się skomunikować z hostem C. W tym celu musi znać adres MAC hosta C. Jak pokazano na diagramie powyżej, host A ma maskę sieci /24. Powoduje to, że host A uważa, że połączony jest z całą siecią 192.168.0.0/24. Gdy komputer musi skomunikować się z innym komputerem bezpośrednio podłączonym do sieci, wysyła żądanie ARP na adres rozgłoszeniowy. Ponadto host A wysyła żądanie ARP a adres MAC hosta C.

Żądanie ARP wysłane na adres rozgłoszeniowy MAC FF:FF:FF:FF:FF:FF. Ponieważ żądanie ARP jest rozgłoszeniowe (broadcast), dotrze do wszystkich hostów w sieci, włączając router R1, ale nie osiągnie hosta C, ponieważ routery domyślnie nie przekierowują sygnałów rozgłoszeniowych. Router z włączonym proxy ARP wie, że host C znajduje się w innej podsieci i odpowie swoim własnym adresem MAC. Router z włączonym proxy ARP zawsze odpowiada swoim własnym adresem MAC jeżeli zna drogę do komputera docelowego.

Takie zachowanie może być użyteczne, np. jeżeli chcesz przydzielić adresy IP klientów 'dial-in' (ppp, pppoe, pptp) z tego samego zakresu adresów co klientom podłączonym do sieci LAN.

Przykład

Rozpatrzmy poniższą konfigurację:

Grafika:arp-proxy-2.jpg

Poniżej przedstawiono konfigurację routera MikroTik:

admin@MikroTik] ip arp> /interface ethernet print
Flags: X - disabled, R - running
  #    NAME                 MTU   MAC-ADDRESS       ARP
  0  R eth-LAN              1500  00:50:08:00:00:F5 proxy-arp
[admin@MikroTik] ip arp> /interface print
Flags: X - disabled, D - dynamic, R - running
  #    NAME                 TYPE             MTU
  0    eth-LAN              ether            1500
  1    prism1               prism            1500
  2 D  pppoe-in25           pppoe-in
  3 D  pppoe-in26           pppoe-in
[admin@MikroTik] ip arp> /ip address print
Flags: X - disabled, I - invalid, D - dynamic
  #   ADDRESS            NETWORK         BROADCAST       INTERFACE
  0   10.0.0.217/24      10.0.0.0        10.0.0.255      eth-LAN
  1 D 10.0.0.217/32      10.0.0.230      0.0.0.0         pppoe-in25
  2 D 10.0.0.217/32      10.0.0.231      0.0.0.0         pppoe-in26
[admin@MikroTik] ip arp> /ip route print
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        G GATEWAY         DIS INTE...
 0 A S  0.0.0.0/0                          r 10.0.0.1        1   eth-LAN
 1 ADC  10.0.0.0/24        10.0.0.217                        0   eth-LAN
 2 ADC  10.0.0.230/32      10.0.0.217                        0   pppoe-in25
 3 ADC  10.0.0.231/32      10.0.0.217                        0   pppoe-in26
[admin@MikroTik] ip arp>

Rozwiązywanie problemów

Opis

* Router pokazuje, że adres IP jest nieprawidłowy

Sprawdź, czy interfejs, adres do niego przydzielony, jest nadany, włączony i działa.