modified on 12 sty 2010 at 08:37 ••• 4 867 views

Dostęp do internetu z VRF

Z MikroTik Wiki

Wymagane pakiety: routing-test, mpls-test, RouterOS wersja 3.23+

Spis treści

Opis

Jest kilka sposobów przydzielenia dostępu do internetu klientom VRF. Część z nich wymieniona jest w RFC 4364 sekcji 11.

W tym artykule zostanie pokazany sposób przydzielenia dostępu z użyciem globalnej tablicy routingu.

Przykład

Image:l3vpn-internet.png

Domyślne trasy

Dodaj domyślne trasy to tablic routingu VRF na PE:

/ip route add routing-mark=cust-one gateway=10.0.0.1@main
/ip route add routing-mark=cust-two gateway=10.0.0.1@main

Należy dokładnie określić która bramka powinna być resolvowana w głównej tablicy routingu, w przeciwnym wypadku trasy nie będą aktywne.

Trasy do sieci klienta

Trasy do sieci klienta powinny być dodane w głównej tablicy routingu, a ich następne skoki powinny być osiągalne przez interfejsy VRF klieta, ponieważ należą do tablic VRF.

Z drugiej strony, nie ma możliwości dokładnego określenia, że bramka musi być resolvowana przez inną tablicę, poza tablicą główną. Zamiast należy określić interfejs (którym jest VRF) i adres bramki następnego skoku (który musi być bezpośrednio osiągalny przez ten interfejs). Dla interfejsu punkt-punkt nie jest wymagane podanie adresu bramki.

Dodaj te trasy do tablicy tras PE i redystrybuuj je przez OSPF:

/ip route add dst-address=10.7.7.0/24 gateway=10.3.3.4%ether2
/ip route add dst-address=10.8.8.0/24 gateway=10.4.4.5%ether3

Tablica routingu powinna wyglądać tak:

[admin@PE2] > /ip route print detail where !routing-mark
 ...
 5 A S  dst-address=10.7.7.0/24 gateway=10.3.3.4 on cust-one reachable ether2 distance=1 scope=30 target-scope=10
  
 6 A S  dst-address=10.8.8.0/24 gateway=10.4.4.5 on cust-two reachable ether3 distance=1 scope=30 target-scope=10