modified on 1 lip 2010 at 11:10 ••• 22 345 views

Dostęp po MAC adresie(Telnet i Winbox)

Z MikroTik Wiki

Spis treści

Opis ogólny

Wprowadzenie

MAC telnet używany jest do zapewnienia dostępu do routera gdy nie ma on przydzielonego adresu IP. Działa podobnie do telnetu IP. MAC telnet działa jedynie pomiędzy dwoma routerami MikroTik RouterOS.

Specyfikacja

Wymagany pakiet: system

Wymagana licencja: level1

Poziom menu: /tool, /tool mac-server

Standardy i technologie: MAC Telnet

Wykorzystanie sprzętu: -

Serwer MAC Telnet

Poziom menu: /tool mac-server

Opis własności

interface (name | all;default: all) - nazwa interfejsu, z którym będzie się łączył klient mac-serwer

- all - wszystkie interfejsy

Uwagi

Na poziomie podmenu znajduje się lista interfejsów. Jeżeli dodasz do listy interfejs, MAC telnet będzie mieć do niego dostęp. Wyłączenie (distabled=yes) pozycji z listy spowoduje, że interfejs nie będzie przyjmował sesji MAC telnet. Ustawienie all jest domyślnym ustawieniem przyjmującym sesje MAC telnet do każdego interfejsu.

Przykład

Aby dla MAC Telnet udostępnić tylko interfejs ether1:

[admin@MikroTik] tool mac-server> print
Flags: X - disabled
# INTERFACE
0 all
[admin@MikroTik] tool mac-server> remove 0
[admin@MikroTik] tool mac-server> add interface=ether1 disabled=no
[admin@MikroTik] tool mac-server> print
Flags: X - disabled
# INTERFACE
0 ether1
[admin@MikroTik] tool mac-server>

Serwer MAC WinBox

Poziom menu: /tool mac-server mac-winbox

Opis własności

interface (name | all; default:all) - nazwa interfejsu, z którym może się łączyć Winbox przy użyciu protokołu opartym na MAC

- all - wszystkie interfejsy

Uwagi

Na poziomie podmenu dostępna jest lista interfejsów. Jeżeli dodasz interfejs do tej listy, udostępnisz go programowi MAC Winbox. Wyłączenie (distabled=yes) pozycji z listy spowoduje, że interfejs nie będzie przyjmował sesji MAC Winbox.

Przykład

Aby dla MAC Winbox udostępnić tylko interfejs ether1:

[admin@MikroTik] tool mac-server mac-winbox> print
Flags: X - disabled
# INTERFACE
0 all
[admin@MikroTik] tool mac-server mac-winbox> remove 0
[admin@MikroTik] tool mac-server mac-winbox> add interface=ether1 disabled=no
[admin@MikroTik] tool mac-server mac-winbox> print
Flags: X - disabled
# INTERFACE
0 ether1
[admin@MikroTik] tool mac-server mac-winbox>

Monitoring Listy Aktywnych Sesji

Poziom menu: /tool mac-server sessions

Opis własności

interface (read-only: name) - interfejs z którym połączony jest klient

src-address (read-only: MAC address) -adres MAC klienta

uptime (read-only: time) - czas połączenia klienta z serwerem

Przykład

Aby zobaczyć listę aktywnych sesji Telnet:

[admin@MikroTik] tool mac-server sessions> print
# INTERFACE SRC-ADDRESS UPTIME
0 wlan1 00:0B:6B:31:08:22 00:03:01
[admin@MikroTik] tool mac-server sessions>

Skanowanie MAC

Polecenie: /tool mac-scan

Opis

Polecenie wykrywa wszystkie urządzenia obsługujące protokół MAC telnet w danej sieci.

Opis własności

(name) - nazwa interfejsu przez który prowadzone jest skanowanie

Klinet MAC Telnet

Polecenie: /tool mac-telnet

Opis własności

(MAC Address) - adres MAC urządzenia

Przykład

Login: admin
Password:
Trying 00:02:6F:06:59:42...
Connected to 00:02:6F:06:59:42

MikroTik RouterOS 3.0beta10 (c) 1999-2007 http://www.mikrotik.com/
Terminal linux detected, using multiline input mode
[admin@MikroTik] >