modified on 1 lip 2010 at 11:20 ••• 11 707 views

Graphing

Z MikroTik Wiki

Spis treści

Informacje Ogólne

Wstęp

Graphing jest to narzędzie używane do monitorowania różnych parametrów RouterOS przez dany okres czasu.

Specyfikacja

Wymagane pakiety: system, routerboard (opcjonalnie)

Wymagane licencje: level1

Poziom Home menu: /tool graphing

Wykorzystanie sprzętowe: nieznaczne

Opis

Graphing może wyświetlać wykresy dla:

  • stan routera (napięcie i temperatura)
  • wykorzystanie zasobów (procesor, pamięć i dysk twardy)
  • ruch przechodzący przez interfejsy
  • ruch przechodzący przez proste kolejki

Graphing składa się z dwóch części - pierwsza część zbiera informacje a druga wyświetla dane na stronie internetowej. Aby uzyskać dostęp do wykresów, wpisz http://[adres_IP_routera]/graphs/ i wybierz wykres, który chcesz zobaczyć w swojej przeglądarce.

Dane są pobierane z routera co 5 minut, ale zapisywane na dysku systemowym co okres store-every. Po restarcie routera, graphing wyświetli informację, kiedy ostatnio zapisywał dane przed restartem.

RouterOS generuje cztery wykresy dla każdego narzędzia:

  • "Daily" Graph (wykres dzienny - średnio co 5 minut)
  • "Weekly" Graph (wykres tygodniowy - średnio co 30 minut)
  • "Monthly" Graph (wykres miesięczny - średnio co 2 godziny)
  • "Yearly" Graph (wykres roczny - średnio co 1 dzień)

Aby uzyskać dostęp do każdego wykresu z sieci, określ tę sieć w parametrze 'allow-address dla odpowiedniego narzędzia.

Ogólne Opcje

Poziom Home menu: /tool graphing

Opis Własności

store-every (5min | hour | 24hour; domyślnie: 5 minut) - jak często mają być zapisywane informacje na dysku

Przykład

Aby zapisywać informacje na dysku systemowym co godzinę:

/tool graphing set store-every=hour
[admin@MikroTik] tool graphing> print
    store-every: hour
[admin@MikroTik] tool graphing>

Wyświetlanie Stanu Routera

Poziom Home menu: /tool graphing health

Opis

To podmenu dostarcza informacje o stanie RouterBoard - napięcie i temperatura. Aby mieć do niego dostęp, musisz zainstalować pakiet routerboard.

Opis Własności

allow-address (IP addressnetmask; domyślnie: 0.0.0.0/0) - sieć, która ma prawo wyświetlania wykresów stanu routera

store-on-disk (yes | no; domyślnie: yes) - czy dane mają być zapisywane na dysku systemowym, czy nie. Jeśli nie, informacje będą przechowywane w pamięci RAM i zostaną utracone po restarcie routera.

Wyświetlanie Stanu Interfejsu

Poziom Home menu: /tool graphing interface

Opis

Pokazuje ile ruchu przeszło przez interfejs przez dany okres czasu.

Opis Własności

allow-address (IP addressnetmask; domyślnie: 0.0.0.0/0) - sieć, która ma prawo wyświetlania wykresów stanu routera

interface (name; domyślnie: all) - nazwa interfejsu, który będzie monitorowany

store-on-disk (yes | no; domyślnie: yes) - czy dane mają być zapisywane na dysku systemowym, czy nie. Jeśli nie, informacje będą przechowywane w pamięci RAM i zostaną utracone po restarcie routera.

Przykład

Aby monitorować ruch przechodzący przez interfejs ether1 tylko z lokalnej sieci 192.168.0.0/24, i zapisywać informacje na dysku:

[admin@MikroTik] tool graphing interface> add interface=ether1 \
\... allow-address=192.168.0.0/24 store-on-disk=yes
[admin@MikroTik] tool graphing interface> print
Flags: X - disabled
 #   INTERFACE ALLOW-ADDRESS      STORE-ON-DISK
 0   ether1    192.168.0.0/24     yes
[admin@MikroTik] tool graphing interface>

Wyświetlanie Stanu Prostej Kolejki

Poziom Home menu: /tool graphing queue

Opis

W tym podmenu możesz określić kolejkę z listy /queue simple, celem sporządzenia wykresu.

Opis Własności

allow-address (IP addressnetmask; domyślnie: 0.0.0.0/0) - sieć, która ma prawo wyświetlania wykresów stanu routera


allow-target (yes | no; domyślnie: yes) - czy dostępna jest strona z wykresami dla adresów IP określonych w /queue simple target-address

simple-queue (name; domyślnie: all) - nazwa prostej kolejki, która będzie monitorowana

store-on-disk (yes | no; domyślnie: yes) - czy dane mają być zapisywane na dysku systemowym, czy nie. Jeśli nie, informacje będą przechowywane w pamięci RAM i zostaną utracone po restarcie routera.

Przykład

Dodaj prostą kolejkę do listy Grapher o nazwie queue1, zezwól klientom na dostęp do Graphera z sieci, na dysku zachowaj informacje o ruchu:

[admin@MikroTik] tool graphing queue> add simple-queue=queue1 allow-address=yes \
\... store-on-disk=yes

Wyświetlanie Stanu Zasobów

Poziom Home menu: /tool graphing resource

Opis

Pokazuje informacje o stanie zasobów routera przez dany okres czasu:

  • użycie procesora
  • użycie pamięci
  • użycie dysku

Opis Własności

allow-address (IP addressnetmask; domyślnie: 0.0.0.0/0) - sieć, która ma prawo wyświetlania wykresów stanu routera

store-on-disk (yes | no; domyślnie: yes) - czy dane mają być zapisywane na dysku systemowym, czy nie. Jeśli nie, informacje będą przechowywane w pamięci RAM i zostaną utracone po restarcie routera.

Przykład

Dodaj adresy IP 192.168.0.0/24 z których użytkownicy mogą monitorować użycie zasobów:

[admin@MikroTik] tool graphing resource> add allow-address=192.168.0.0/24 \
\... store-on-disk=yes
[admin@MikroTik] tool graphing resource> print
Flags: X - disabled
 #   ALLOW-ADDRESS      STORE-ON-DISK
 0   192.168.0.0/24     yes
[admin@MikroTik] tool graphing resource>