modified on 21 lip 2010 at 09:25 ••• 14 148 views

Interfejs/Bonding

Z MikroTik Wiki

Spis treści

Monitorowanie Łącza ARP

Wstęp

To jest przykład agregacji wielu interfejsów sieciowych w jeden strumień. Pokazane jest jak łączyć wiele wirtualnych (EoIP) interfejsów w celu osiągnięcia maksymalnej przepustowości z naciskiem na dostępność.

Cel

Nauczysz się jak łączyć zdalne lokacje przez wiele fizycznych łączy. Połączony strumień będzie umożliwiał osiągnięcie większej przepustowości i dostępności niż oddzielne łącza.

Schemat Sieci

Dwa routery R1 i R2 są połączone ze sobą przez wieloskokowe łącza bezprzewodowe. Bezprzewodowe interfejsy po obu stronach mają przydzielony adres IP.

Image:Bonding ARP Monitoring Exam.jpg

Zaczynamy

Bonding może być użyty tylko w połączeniach warstwy 2 modelu OSI (poziom Ethernetu). Z tego powodu musimy stworzyć interfejsy EoIP na każdym łączu bezprzewodowym. Poniżej opisano procedurę:

  • na routerze R1:
[admin@MikroTik] > /interface eoip add remote-address=10.0.1.1/24 tunnel-id=1
[admin@MikroTik] > /interface eoip add remote-address=10.0.2.1/24 tunnel-id=2
  • na routerze R2
[admin@MikroTik] > /interface eoip add remote-address=10.1.1.1/24 tunnel-id=1
[admin@MikroTik] > /interface eoip add remote-address=10.2.2.1/24 tunnel-id=2

Drugim krokiem jest dodanie interfejsu łączonego i określenie interfejsów EoIP jako podrzędne:

  • na routerze R2
[admin@MikroTik] > / interface bonding add slaves=eoip-tunnel1,eoip-tunnel2 mode=balance-rr 

Zajrzyj na tę stronę w celu dowiedzenia się więcej o wyboru trybu bondingu.

  • na routerze R2
[admin@MikroTik] > / interface bonding add slaves=eoip-tunnel1,eoip-tunnel2 mode=balance-rr 

Na koniec dodaj adresy IP do interfejsów złączonych:

  • na routerze R1:
[admin@MikroTik] > / ip address add address 192.168.0.1/24 interface=bonding1

Zajrzyj na tę stronę w celu dowiedzenia się więcej o wyboru trybu bondingu.

  • na routerze R2
[admin@MikroTik] > / ip address add address 192.168.0.2/24 interface=bonding1 

Test konfiguracji

Teraz dwa routery mają dostęp do siebie nawzajem używając adresów z sieci 192.168.0.0/25. Aby sprawdzić sprawność interfeju:

  • na routerze R1:
[admin@MikroTik] > /interface monitor-traffic eoip-tunnel1,eoip-tunnel2
  • na routerze R2
[admin@MikroTik] > /tool bandwidth-test 192.168.0.1 direction=transmit

Powinieneś zauważyć, że ruch jest rozdzielany równo pomiędzy obydwa interfejsy EoIP:

[admin@MikroTik] > /int monitor-traffic eoip-tunnel1,eoip-tunnel2              
    received-packets-per-second: 685      685                                  
       received-bits-per-second: 8.0Mbps  8.0Mbps                              
        sent-packets-per-second: 21       20                                   
           sent-bits-per-second: 11.9kbps 11.0kbps                             
    received-packets-per-second: 898      899                                  
       received-bits-per-second: 10.6Mbps 10.6Mbps                             
        sent-packets-per-second: 20       21                                   
           sent-bits-per-second: 11.0kbps 11.9kbps                             
    received-packets-per-second: 975      975                                  
       received-bits-per-second: 11.5Mbps 11.5Mbps                             
        sent-packets-per-second: 22       22                                   
           sent-bits-per-second: 12.4kbps 12.3kbps                             
    received-packets-per-second: 980      980                                  
       received-bits-per-second: 11.6Mbps 11.6Mbps                             
        sent-packets-per-second: 21       21                                   
           sent-bits-per-second: 11.9kbps 11.8kbps                             
    received-packets-per-second: 977      977                                  
       received-bits-per-second: 11.6Mbps 11.5Mbps                             
        sent-packets-per-second: 21       21                                   
           sent-bits-per-second: 11.9kbps 11.8kbps                             
-- [Q quit|D dump|C-z pause]
[admin@MikroTik] >

Monitorowanie Łącza

Z łatwością można zauważyć, że powyższa konfiguracja przestanie działać, jeśli jedno z poszczególnych łączy ulegnie awarii. Dzieje się tak, ponieważ nie jest stosowany monitoring łącza. Sterownik bondingu nie ma możliwości uzyskania informacji o problemach z łączami niższej warstwy. Monitoring łącza jest konieczny przy większości konfiguracji. Aby włączyć monitoring łączą ARP (rekomendowany):

  • na routerze R1:
[admin@MikroTik] > / interface bonding set bonding1 link-monitoring=arp arp-ip-targets=192.168.0.2
  • na routerze R2
[admin@MikroTik] > / interface bonding set bonding1 link-monitoring=arp arp-ip-targets=192.168.0.1

Zobacz również