modified on 20 lip 2010 at 12:35 ••• 11 617 views

Interfejs/IPIP

Z MikroTik Wiki

Spis treści

Informacje Ogólne

Wstęp

Tunelowanie IPIP w MikroTik RouterOS podlega RFC 2003. Tunel IPIP jest prostym protokołem, który dokonuje enkapsulacji pakietów IP aby stworzyć tunel między dwoma routerami. Interfejs tunelu IPIP pojawia się jako interfejs pod listą interfejsów. Wiele routerów (także Cisco i bazujących na linuksie) obsługuje ten protokół. Ten protokół umożliwia tworzenie wielorakich sieci.

Protokół tunelowania IP dodaje następujące opcje do ustawień sieciowych:

  • tunelowanie Intranetowe przez Internet
  • używanie tego zamiast routowania źródłowego

Przewodnik po Szybkiej Konfiguracji

Aby stworzyć tunel IPIP pomiędzy dwoma routerami MikroTik o adresach 10.5.8.104 i 10.1.0.172, używając adresów IPIP 10.0.0.1 i 10.0.0.2 wykonaj następujące kroki.

  • Konfiguracja routera o adresie 10.5.8.104:

1. Dodaj interfejs IPIP (domyślnie będzie to nazwa ipip1)

[admin@MikroTik] interface ipip> add local-address=10.5.8.104 \
remote-address=10.1.0.172 disabled=no

2. Dodaj adres IP do interfejsu ipip1:

[admin@MikroTik] ip address> add address=10.0.0.1/24 interface=ipip1
  • Konfiguracja routera o adresie 10.1.0.172:

1. Dodaj interfejs IPIP (domyślnie będzie to nazwa ipip1)

[admin@MikroTik] interface ipip> add local-address=10.1.0.172 \
remote-address=10.5.8.104 disabled=no

2. Dodaj adres IP do stworzonego interfejsu ipip1:

[admin@MikroTik] ip address> add address=10.0.0.2/24 interface=ipip1

Specyfikacja

Wymagane pakiety: system

Wymagane licencje: level1 (ograniczenie do jednego tunelu), level3 (200 tuneli), level5 (bez ograniczeń)

Poziom Home menu: /interface ipip

Standardy i Technologie: IPIP (RFC 2003)

Wykorzystanie sprzętu: nieznaczne

Dodatkowe Dokumenty

  • RFC1853
  • RFC2003
  • FRC1241

Ustawienia IPIP

Poziom Home menu: /interface ipip

Opis

Interfejs IPIP powinien być konfigurowany na dwóch routerach, które mają możliwość połączenia przez IP i są zgodne z RFC 2003. Tunel IPIP może działać na każdym połączeniu, który transportuje pakiety IP. Każdy interfejs tunelu IPIP może się połączyć z jednym zdalnym routerem, który ma skonfigurowany interfejs komunikacyjny. Do routera można dodać nieskończoną liczbę tuneli IPIP. Pomiędzy dwoma adresami IP może być tylko jeden tunel, więc jeśli chcesz utworzyć kilka różnych tuneli pomiędzy tymi samymi hostami, użyj więcej niż jeden adres IP. W RFC 2003 znajduje się więcej szczegółów o tunelach IPIP.

Opis Własności

local-address (IP address) - lokalny adres routera, który rozsyła ruch IPIP do zdalnego hosta

mtu (integer; domyślnie: 1480) - Maximum Transmission Unit (Maksymalna Jednostka Transmisyjna). Powinna być ustawiona wartość 1480B, aby uniknąć fragmentacji pakietów. Można ustawić wartość na 1500B jeśli wykrywanie ścieżki mtu nie działa poprawnie na połączeniach.

name (name; domyślnie: ipipN) - nazwa interfejsu

remote-address (IP address) - adres IP zdalnego hosta tunelu IPIP - może być jakikolwiek router zgodny z RFC 2003

Uwagi

Użyj komendę /ip address add aby przydzielić adres IP do interfejsu IPIP.

W tym interfejsie nie ma autentykacji. Użycie pasma przez interfejs może być monitorowane przez narzędzie monitor w menu interface'.

Implementacja MikroTik RouterOS IPIP była testowana na Cisco 1005. Konfiguracja tego routera wygląda następująco:

interface Tunnel0
ip address 10.3.0.1 255.255.255.0
tunnel source 10.0.0.171
tunnel destination 10.0.0.204
tunnel mode ipip

Przykłady Aplikacji

Opis

Załóżmy, że chcemy dodać tunel IPIP pomiędzy routerami R1 i R2:

Grafika:ipip.jpg

Najpierw musimy skonfigurować interfejsy IPIP a następnie dodać do nich adresy IP.

Konfiguracja routera R1 przebiega następująco:

[admin@MikroTik] interface ipip> add
local-address: 10.0.0.1
remote-address: 22.63.11.6
[admin@MikroTik] interface ipip> print
Flags: X - disabled, R - running, D - dynamic
  #    NAME                         MTU   LOCAL-ADDRESS   REMOTE-ADDRESS
  0 X  ipip1                        1480  10.0.0.1        22.63.11.6
[admin@MikroTik] interface ipip> enable 0
[admin@MikroTik] interface ipip> /ip address add address 1.1.1.1/24 interface=ipip1

Konfiguracja R2 przedstawiona jest poniżej:

[admin@MikroTik] interface ipip> add local-address=22.63.11.6 remote-address=10.0.0.1
[admin@MikroTik] interface ipip> print
Flags: X - disabled, R - running, D - dynamic
  #    NAME                         MTU   LOCAL-ADDRESS   REMOTE-ADDRESS
  0 X  ipip1                        1480  22.63.11.6      10.0.0.1
[admin@MikroTik] interface ipip> enable 0
[admin@MikroTik] interface ipip> /ip address add address 1.1.1.2/24 interface=ipip1

Teraz oba routery mogą się pingować:

[admin@MikroTik] interface ipip> /ping 1.1.1.2
1.1.1.2 64 byte ping: ttl=64 time=24 ms
1.1.1.2 64 byte ping: ttl=64 time=19 ms
1.1.1.2 64 byte ping: ttl=64 time=20 ms
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 19/21.0/24 ms
[admin@MikroTik] interface ipip>