modified on 20 lip 2010 at 12:35 ••• 58 886 views

Interfejs/PPPoE

Z MikroTik Wiki

Spis treści

Informacje Ogólne

Wprowadzenie

Protokół PPPoE (Point to Point Protocol over Ethernet) pozwala na zarządzanie użytkownikami, sieciami oraz kontami, ISP(Internet Service Provider - Dostawca Usługi dostępu do Internetu) i administratorom sieci. Aktualnie PPPoE jest używany głównie przez ISP w celu kontroli połączeń klienckich przez xDSL i modemy jak i w zwykłych sieciach Ethernetowych. PPPoE jest rozszerzeniem standardu PPP (Point to Point Protocol). Różnica pomiędzy nimi polega na metodzie transportu: PPPoE wykorzystuje Ethernet zamiast modemowych połączeń szeregowych.

Ogólnie mówiąc, PPPoE używany jest aby przydzielać adresy IP klientom w oparciu o uwierzytelnianie poprzez podanie nazwy użytkownika (i stacji roboczej, o ile będzie taka potrzeba), odróżnieniu od uwierzytelnienia w oparciu o stację roboczą, jak ma to miejsce, gdy użyta jest statyczna adresacja IP lub przez DHCP. Zaleca się nie używać statycznej adresacji IP lub DHCP na tych samych interfejsach co PPPoE z oczywistych powodów mających wpływ na bezpieczeństwo.

MikroTik RouterOS może zachowywać się jak klient RADIUS - możesz użyć serwera RADIUS w celu uwierzytelniania klientów PPPoE i prowadzenie rachunku abonenta.

Połączenie PPPoE składa się z klienta i koncentratora dostępu (serwera). Klientem może być każdy komputer posiadający zainstalowany protokół klienta PPPoE. MikroTik RouterOS wspiera obie strony PPPoE - klienta i koncentratora dostępu. Klient i serwer PPPoE działają poprzez dowolny interfejs poziomu Ethernetu na routerze - bezprzewodowy 802.11 (Aironet, Cisco, WaveLan, Prism, Atheros), 10/100/1000 Mbit/s Ethernet, RadioLan i EoIP (Ethernet over IP tunnel). Szyfrowanie MPPE 40bitowe RSA i MPPE 128bitowe RSA również jest wspierane.

Multilink PPP (MP) jet wspierane w celu zapewnienia MRRU (zdolność transmisji całych pakietów 1500 i większych) i połączeń mostkowych poprzez łącza PPP (przy użyciu Bridge Control Protocol (BCP) pozwalającym na wysyłanie niezmienionych ramek ethernetowych przez łącza PPP). W ten sposób możliwe jest zestawianie połączeń mostkowych bez EoIP. Mostek powinien mieć ustawiony administracyjnie adres MAC lub interfejs ethernetopodobny, ponieważ łącza PPP nie mają adresó MAC.

Pamiętaj, że gdy serwer RADIUS uwierzytelnia użytkownika poprzez CHAP, MS-CHAPv1 lub MS-CHAPv2, protokół RADIUS nie używa wspólnego hasła, które jest używany tylko w pakiecie odpowiedzi uwierzytelnienia. Więc, gdy posiadasz złe wspólne hasło, serwer RADIUS zaakceptuje zapytanie. Możesz użyć polecenia /radius monitor aby zobaczyć parametr bad-replies. Jego wartość powinna rosnąć za każdym razem, gdy klient próbuje się połączyć.

Obsługiwane połączenia:

  • MikroTik RouterOS PPPoE jako klient z dowolnym serwerem PPPPoE (koncentratorem dostępu)
  • MikroTik RouterOS jako serwer z wieloma klientami PPPoE (klienci PPPoE dostępni są w prawie wszystkich systemach operacyjnych i większości routerów)

Przewodnik Szybkiej Konfiguracji

  • W celu konfiguracji MikroTik RouterOS jako klienta PPPoE

1. Po prostu dodaj klienta PPPoE:

/interface pppoe-client add name=pppoe-user-mike user=user password=passwd \
\... interface=wlan1 service-name=internet disabled=no
  • W celu konfiguracji MikroTik RouterOS jako Koncentratora Dostępu (Serwera PPPoE)

1. Dodaj pule adresów dla klientów od 10.1.1.62 do 10.1.1.72, nazywaną pppoe-pool:

/ip pool add name="pppoe-pool" ranges=10.1.1.62-10.1.1.72

2. Dodaj profil PPP nazywany pppoe-profile gdzie local-address będzie adresem routera, do którego klienci będą mieli dostęp z adresu przydzielonego z pppoe-pool:

/ppp profile add name="pppoe-profile" local-address=10.1.1.1 remote-address=pppoe-pool

3. Dodaj użytkownika o nazwie mike i haśle 123:

/ppp secret add name=user password=passwd service=pppoe profile=pppoe-profile

4. Teraz dodaj serwer pppoe:

/interface pppoe-server server add service-name=internet interface=wlan1 \
\... default-profile=pppoe-profile

Specyfikacja

Wymagane pakiety: ppp

Wymagana licencja: Level1 (ograniczenie do 1 interfejsu), Level3 (ograniczenie do 200 interfejsów), Level4 (ograniczenie do 200 interfejsów), Level5 (ograniczenie do 500 interfejsów), Level6 (brak ograniczenia)

Poziom menu: /interface pppoe-server, /interface pppoe-client

Standardy i technologie: PPPoE (RFC 2516)

Wykorzystanie sprzętu: serwer PPPoE może wymagać dodatkowej pamięci RAM (używa około 9 KB (plus dodatkowe 10 KB na kolejkowanie pakietów, jeżeli użyte jest ograniczenie szerokości pasma) na każde połączenie) i mocy CPU. Maksymalnie obsługiwanych jest 65535 połączeń.

Dodatkowe Źródła

Link do dokumentacji PPPoE:

Klienci PPPoE:

  • RASPPoE dla Windows 95, 98, 98SE, ME, NT4, 2000, XP, .NET

http://www.raspppoe.com/

Konfiguracja Klienta PPPoE

Poziom menu: /interface pppoe-client

Opis Własności

ac-name (text; default: "") - może być puste, a klient będzie się łączył z dowolnym koncentratorem dostępu, który oferuje wybraną "service name"

add-default-route (yes | no; default: no) - określa, czy automatycznie dodawać domyślą trasę

allow (multiple choice: mschap2, mschap1, chap, pap; default: mschap2, mschap1, chap, pap) - protokół używany przez klienta w celu uwierzytelnienia

dial-on-demand (yes | no; default: no) - łączy z AC (Koncentratorem Dostępu) tylko wtedy, kiedy generowany jest wychodzący ruch i rozłącza gdy nie ma ruchu przez czas ustawiony w parametrze "idle-timeout"

interface (name) - interfejs serwera PPPoE przez który jest dostępny serwer

max-mru (integer; default: 1460) - Maximum Receive Unit. Optymalną wartością jest MRU interfejsu, na którym działa tunel, pomniejszoną o 40 (dla łącza ethernetowego 1500-bajtowego, ustaw MRU na 1460 aby uniknąć fagmentacji pakietów)

max-mtu (integer; default: 1460) - Maximum Transmission Unit.Optymalną wartością jest MTU interfejsu, na którym działa tunel, pomniejszoną o 40 (dla łącza ethernetowego 1500-bajtowego, ustaw MRU na 1460 aby uniknąć fagmentacji pakietów)

mrru (integer: 512..65535; default: disabled) - maksymalny rozmiar pakietów, jaki może być odebrany przez łącze. Jeżeli pakiet jest większy niż MTU tunelu, zostanie podzielony na wiele pakietów, pozwalając pakietom IP lub Ethernet o pełnym rozmiarze być przesłanym przez tunel

  • disabled - wyłącz MRRU dla tego łącza

name (name; default: pppoe-out1) - nazwa interfejsu PPPoE

password (text; default: "") - hasło użytkownika używane do łączenia z serwerem PPPoE

profile (name) - domyślny profil połączenia

service-name (text; default: "") - określa nazwę usługi ustawionej w koncentratorze dostępu. Pozostaw wartość pusta, chyba, że masz wiele usług i potrzebujesz określić, z którym chcesz się połączyć

use-peer-dns (yes | no; default: no) - określa, czy ustawić domyślny DNS routera na DNS peera PPP (np. czy otrzymywać ustawienia DNS od peera)

user (text; default: "") - nazwa użytkownika na serwerze PPPoE

Uwagi

Uwaga dla Windows. Niektóre instrukcje połączenia mogą używać formy, w której "phone number", jak na przykład "MikroTik_AC\mt1", opisany jest, aby wskazywał, że "MikroTik_AC" jest nazwą koncentratora dostępu, a "mt1" jest nazwą usługi

Określanie MRRU oznacza włączanie MP (Multilink PPP) przez pojedyncze łącze. Ten protokół używany jest do rozdzielania dużych pakietów na mniejsze. W Windowsie może być to włączone w zakładce Sieci, przycisk Ustawienia, "Negocjuj multiłącze przez połączenia jednołączowe". Ich MRRU jest ustawione na 1614. To ustawienie jest użyteczne aby przezwyciężyć awarię PathMTU discovery. MP powinien być łączony na obu hostach.

Przykład

Aby dodać i włączyć klienta PPPoE na interfejsie ether1 łącząc z AC, który zapewnia usługę testSN przy użyciu nazwy użytkownika user i haśle passwd:

[admin@RemoteOffice] interface pppoe-client> add interface=ether1 \
\... service-name=testSN user=user password=passwd disabled=no
[admin@RemoteOffice] interface pppoe-client> print
Flags: X - disabled, R - running
 0  R name="pppoe-out1" max-mtu=1480 max-mru=1480 mrru=disabled interface=ether1
      user="user" password="passwd" profile=default service-name="testSN"
      ac-name="" add-default-route=no dial-on-demand=no use-peer-dns=no
      allow=pap,chap,mschap1,mschap2
[admin@RemoteOffice] interface pppoe-client>

Monitorowanie Klienta PPPoE

Nazwa polecenia: /inteface pppoe-client monitor

Opis Własności

ac-mac (MAC address) - adres MAC koncentratora dostępu (AC), z którym połączony jest klient

ac-name (text) - nazwa AC, z którym połączony jest klient

encoding (text) - szyfrowanie i kodowanie (jeśli asymetryczne, oddzielone '/') używane w tym połączeniu

mru (read-only: integer) - efektywne MRU łącza

mtu (read-only: integer) - efektywne MTU łącza

service-name (text) - nazwa usługi, z którą połączony jest klient

status (text) - status klienta

  • dialing - próba zestawienia połączenia
  • verifying password... - połączenie z serwerem zostało zestawione, trwa weryfikacja hasła
  • connected - połączenie z serwerem
  • terminated - interfejs nie jest włączony, lub druga strona nie zestawia połączenia

uptime (time) - czas połączenia w dniach, godzinach, minutach i sekundach

Przykład

Aby monitorować połączenie pppoe-out1:

[admin@MikroTik] interface pppoe-client> monitor pppoe-out1
        status: "connected"
        uptime: 6s
     idle-time: 6s
      encoding: "MPPE128 stateless"
  service-name: "testSN"
       ac-name: "MikroTik"
        ac-mac: 00:0C:42:04:00:73
           mtu: 1480
           mru: 1480

[admin@MikroTik] interface pppoe-client>

Konfiguracja Serwera PPPoE (Koncentratora Dostępu)

Poziom menu: /interface pppoe-server server

Opis

Serwer PPPoE (koncentrator dostępu) ma możliwość uruchomienia wielu serwerów na każdym interfejsie - z różnymi nazwami usług. Aktualnie przepustowość serwera PPPoE została przetestowana i wynosi do 160 Mb/s na procesorze Celeron 600. Używając szybszego CPU, przepustowość powinna wzrosnąć proporcjonalnie.

Access concentrator name i service name PPPoE używane są przez klientów w celu zidentyfikowania, z którym koncentratorem dostępu się rejestrować. Access concentrator name jest takie same jak identity wyświetlone na routerze przed znakiem zachęty. Nazwa serwera (identity) może być ustawiona w menu /system identity.

Pamiętaj, że jeśli nie ma określonej nazwy usługi w WindowsXP, zostanie użyta usługa bez nazwy. Więc, jeśli chcesz obsługiwać klientów WindowsXP, pozostaw nazwę swojej usługi pustą.

Opis Własności

authentication (multiple choice: mschap2 | mschap1 | chap | pap; default: mschap2, mschap1, chap, pap) - algorytm uwierzytelnienia

default-profile (name; default: default) - domyślny profil użytkownika

interface (name) - interfejs, z którym połączony jest klient

keepalive-timeout (time; default: 10) - definiuje przedział czasu (w sekundach), po którym router zaczyna wysyłać pakiety keepalive co sekundę. Jeśli ruch będzie zerowy, i przez ten czas nie przyjdzie odpowiedź (np. 2* keepalive-timeout), nie odpowiadający klient uznany zostaje za rozłączony.

max-mru (integer; default: 1480) - Maximum Receive Unit.Optymalną wartością jest MRU interfejsu, na którym działa tunel, pomniejszoną o 20 (dla łącza ethernetowego 1500-bajtowego, ustaw MRU na 1420 aby uniknąć fagmentacji pakietów)

max-mtu (integer; default: 1480) - Maximum Transmission Unit.Optymalną wartością jest MTU interfejsu, na którym działa tunel, pomniejszoną o 20 (dla łącza ethernetowego 1500-bajtowego, ustaw MRU na 1420 aby uniknąć fagmentacji pakietów)

max-sessions (integer; default: 0) - maksymalna ilość klientów, która może obsłużyć AC

  • 0 - nieograniczona

mrru (integer: 512..65535; default: disabled) - maksymalny rozmiar pakietów, jaki może być odebrany przez łącze. Jeżeli pakiet jest większy niż MTU tunelu, zostanie podzielony na wiele pakietów, pozwalając pakietom IP lub Ethernet o pełnym rozmiarze być przesłanym przez tunel

  • disabled - wyłącz MRRU dla tego łącza

one-session-per-host (yes | no; default: no) - zezwóln tylko na jedną sesję na hosta (określone przez adres MAC). Jeśli host będzie próbował ustanowić nową sesję, stara zostanie zamknięta

service-name (text) - nazwa usługi PPPoE

Uwagi

Domyślna wartość keemalive-timeout ustawiona jest na 10, co w większości przypadku jest dobre. Jeżeli ustawisz to na 0, router nie będzie rozłączał klientów dopóki nie wylogują się lub serwer nie zostanie zrestartowany. Aby rozwiązać ten problem, może zostać użyty parametr one-sesion-per-host.

Uwaga bezpieczeństwa: nie przydzielaj adresu IP do interfejsu, na którym będziesz odbierał zapytania PPPoE.

Określanie MRRU oznacza włączanie MP (Multilink PPP) przez pojedyncze łącze. Ten protokół używany jest do rozdzielania dużych pakietów na mniejsze. W Windowsie może być to włączone w zakładce Sieci, przycisk Ustawienia, "Negocjuj multiłącze przez połączenia na jednołączowe". Ich MRRU jest ustawione na 1614. To ustawienie jest użyteczne aby przezwyciężyć awarię PathMTU discovery. MP powinien być łączony na obu hostach.

Przykład

Aby dodać serwer PPPoE na interfejsie ether1 zapewniając usługę ex i zezwalając tylko jedno połączenie na hosta:

[admin@MikroTik] interface pppoe-server server> add interface=ether1 \
\... service-name=ex one-session-per-host=yes
[admin@MikroTik] interface pppoe-server server> print
Flags: X - disabled
  0 X service-name="ex" interface=ether1 mtu=1480 mru=1480 mrru=disabled
      authentication=mschap2,mschap,chap,pap keepalive-timeout=10
      one-session-per-host=yes max-sessions=0 default-profile=default
[admin@MikroTik] interface pppoe-server server>

Interfejsy Tunelu PPPoE

Poziom menu: /interface pppoe-server

Opis

Są dwa typy obiektów interfejsów (tuneli) w konfiguracji serwera PPTP - statyczni użytkownicy i dynamiczne połączenia. Interfejs jest tworzony dla każdego zestawionego tunelu z danym serwerem. Statyczne interfejsy dodawane są administracyjnie, jeżeli jest potrzeba odwołania do konkretnej nazwy interfejsu (w regułach firewalla lub gdzieś indziej) stworzonej przez konkretnego użytkownika. Dynamiczne interfejsy dodawane są do tej listy automatycznie gdy użytkownik jest połączony i jego nazwa nie pasuje z istniejącym wpisem statycznym (np. w firewallu), więc, jeśli potrzebujesz trwałych reguł dla tego użytkownika, stwórz dla niego/niej wpis statyczny. W przeciwnym wypadku bezpiecznie jest użyć konfiguracji dynamicznej. Pamietaj, że w obu przypadkach użytkownicy PPP muszą być poprawnie skonfigurowani - statyczne wpisy nie nadpisują konfiguracji PPP.

Opis Własności

encoding (text) - szyfrowanie i kodowanie (jeśli asymetryczne, oddzielone '/') używane w tym połączeniu

mru (read-only: integer) - efektywne MRU łącza

mtu (read-only: integer) - efektywne MTU łącza

name (name) - nazwa interfejsu

remote-address (read-only: MAC address) - adres MAC klienta, z którym jest zestawione połączenie

service (name) - nazwa usługi, z która jest połączony klient

uptime (read-only: time) - pokazuje jak długo klient jest połączony

user (name) - nazwa połączonego użytkownika (musi być wpisany w bazę danych użytkowników)

Przykład

Aby zobaczyć aktualnie połączonych użytkowników:

[admin@MikroTik] interface pppoe-server> print
Flags: X - disabled, D - dynamic, R - running 
 #     NAME       USER      SERVICE   REMOTE... ENCODING  UPTIME
 0  DR <pppoe-ex> user      ex        00:0C:... MPPE12... 40m45s
[admin@MikroTik] interface pppoe-server>

Aby rozłączyć użytkownika ex:

[admin@MikroTik] interface pppoe-server> remove [find user=ex]
[admin@MikroTik] interface pppoe-server> print

[admin@MikroTik] interface pppoe-server>

Przykłady Aplikacji

PPPoE w wielopunktowej sieci bezprzewodowej 802.11g

W sieci bezprzewodowej, serwer PPPoE może być dołączony do Punktu Dostępowego (Access Point)(jak również do normalnej stacji w infrastrukturze bezprzewodowej). Klient RouterOS lub klienci Windows PPPoE mogą łączyć się z Punktem Dostępowym w celu uwierzytelnienia PPPoE. To optymalizuje transmisję pakietów 1500-bajtowych i pozwala uniknąć problemów związanych z MTU mniejszym niż 1500. Dotychczas nie wiadomo jak zmienić MTU na interfejsach bezprzewodowych systemu Windows.

Rozważmy poniższą konfigurację, gdzie bezprzewodowy AP MikroTik oferuje bezprzewodowym klientom przezroczysty dostęp do lokalnej sieci z uwierzytelnieniem: Grafika:ppoe-appex.jpg

Najpierw, interfejs bezprzewodowy powinien zostać skonfigurowany:

[admin@PPPoE-Server] interface wireless> set 0 mode=ap-bridge \
   frequency=2442 band=2.4ghz-b/g ssid=mt disabled=no
[admin@PPPoE-Server] interface wireless> print
Flags: X - disabled, R - running 
 0 X  name="wlan1" mtu=1500 mac-address=00:0C:42:18:5C:3D arp=enabled
      interface-type=Atheros AR5413 mode=ap-bridge ssid="mt" frequency=2442
      band=2.4ghz-b/g scan-list=default antenna-mode=ant-a wds-mode=disabled
      wds-default-bridge=none wds-ignore-ssid=no default-authentication=yes
      default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0
      hide-ssid=no security-profile=default compression=no
[admin@PPPoE-Server] interface wireless>

Teraz konfiguracja interfejsu ethernetowego, dodanie adresu IP i określenie trasy domyślnej:

[admin@PPPoE-Server] ip address> add address=10.1.0.3/24 interface=Local
[admin@PPPoE-Server] ip address> print
Flags: X - disabled, I - invalid, D - dynamic
 #   ADDRESS            NETWORK         BROADCAST       INTERFACE
 0   10.1.0.3/24        10.1.0.0        10.1.0.255      Local
[admin@PPPoE-Server] ip address> /ip route
[admin@PPPoE-Server] ip route> add gateway=10.1.0.1
[admin@PPPoE-Server] ip route> print
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        G GATEWAY         DISTANCE INTER...
 0 ADC  10.1.0.0/24        10.1.0.3                          0        Local
 1 A S  0.0.0.0/0                          r 10.1.0.1        1        Local
[admin@PPPoE-Server] ip route> /interface ethernet
[admin@PPPoE-Server] interface ethernet> set Local arp=proxy-arp
[admin@PPPoE-Server] interface ethernet> print
Flags: X - disabled, R - running
 #    NAME                                   MTU   MAC-ADDRESS       ARP
 0  R Local                                  1500  00:0C:42:03:25:53 proxy-arp
[admin@PPPoE-Server] interface ethernet>

Powinniśmy dodać serwer PPPoE do interfejsu bezprzewodowego:

[admin@PPPoE-Server] interface pppoe-server server> add interface=wlan1 \
   service-name=mt one-session-per-host=yes disabled=no
[admin@PPPoE-Server] interface pppoe-server server> print
Flags: X - disabled
 0   service-name="mt" interface=wlan1 max-mtu=1480 max-mru=1480 mrru=disabled
     authentication=pap,chap,mschap1,mschap2 keepalive-timeout=10
     one-session-per-host=yes max-sessions=0 default-profile=default
[admin@PPPoE-Server] interface pppoe-server server>

Na końcu, można dodać klientów PPPoE:

[admin@PPPoE-Server] ip pool> add name=pppoe ranges=10.1.0.100-10.1.0.200
[admin@PPPoE-Server] ip pool> print
 # NAME                                         RANGES
 0 pppoe                                        10.1.0.100-10.1.0.200
[admin@PPPoE-Server] ip pool> /ppp profile
[admin@PPPoE-Server] ppp profile> set default use-encryption=yes \
   local-address=10.1.0.3 remote-address=pppoe
[admin@PPPoE-Server] ppp profile> print
Flags: * - default
 0 * name="default" local-address=10.1.0.3 remote-address=pppoe
     use-compression=no use-vj-compression=no use-encryption=yes only-one=no
     change-tcp-mss=yes

 1 * name="default-encryption" use-compression=default
     use-vj-compression=default use-encryption=yes only-one=default
     change-tcp-mss=default
[admin@PPPoE-Server] ppp profile> .. secret
[admin@PPPoE-Server] ppp secret> add name=w password=wkst service=pppoe
[admin@PPPoE-Server] ppp secret> add name=l password=ltp service=pppoe
[admin@PPPoE-Server] ppp secret> print
Flags: X - disabled
 #   NAME        SERVICE CALLER-ID PASSWORD  PROFILE            REMOTE-ADDRESS
 0   w           pppoe             wkst      default            0.0.0.0
 1   l           pppoe             ltp       default            0.0.0.0
[admin@PPPoE-Server] ppp secret>

W ten sposób zakończyliśmy konfigurację i dodaliśmy dwóch użtkowników: w i l, którzy mogą połączyć się z internetem, przy użyciu oprogramowania klienckiego PPPoE.

Pamiętaj, że wbudowany klient Windows XP wspiera szyfrowanie, ale RASPPOE nie. Więc, jeśli planowane jest obsługiwanie klientów Windows starszych niż Windows XP, zaleca się niewymuszanie szyfrowania. W przeciwnym wypadku, serwer będzie akceptował klientów, którzy nie szyfrują danych.

Rozwiązywanie Problemów

Opis

  • Nie mogę połączyć się ze swoim serwerem PPPoE. Ping przez niego przechodzi, ale nie mogę otwierać stron www

Upewnij się, że określiłeś poprawny serwer DNS na routerze (w /ip dns lub /ppp profile parametr dns-server).

  • Serwer PPPoE pokazuje więcej niż jeden wpisów aktywnych użytkowników na jednego klienta, gdy klient się rozłącza, nadal pokazywani są jako aktywni

Ustaw parametr keepalive-timeout (w konfiguracji serwera PPPoE) na 10 jeśli chcesz aby klienci byli uważani za wylogowanych gdy nie odpowiadają przez 10 sekund

Pamiętaj, że gdy parametr keepalive-timeout ustawiony jest na 0, a parametr only-one (w ustawieniach profilu PPP) ustawiony jest na yes, to klienci mogą łączyć się tylko raz. Aby rozwiązać ten problem, parametr one-session-per-host w konfiguracji serwera PPPoE powinien mieć wartość yes

  • Mój klient Windowsa XP nie może połączyć się z serwerem PPPoE

Musisz określić "Nazwę Usługi" w ustawieniach klienta XP PPPoE. Jeśli nie ma ustawionej nazwy usługi, lub nie jest taka sama jak nazwa usługi na serwerze MikroTik, będziesz otrzymywać błędy "linia zajęta", lub system będzie pokazywał "weryfikacja hasła - nieznany błąd"

  • Chcę rejestrować (logs) zestawienia połączeń PPPoE

Skonfiguruj usługę logowania w /system logging facility i włącz logi typu PPP.