modified on 27 mar 2008 at 20:41 ••• 6 688 views

Konfiguracja linku w trybie n-streme2

Z MikroTik Wiki

Do zestawienia linku za pomocą trybu nstreme-2 są potrzebne dwa komputery posiadające po 2 karty radiowe.


Dla pierwszego komputera.

/interface wireless set wlan1 country=poland /interface enable wlan1 /interface enable wlan2 /interface bridge add /interface bridge port add interface=ether1 bridge=bridge1 /interface wireless set wlan1 mode=nstreme-dual-slave /interface wireless set wlan2 mode=nstreme-dual-slave /interface wireless nstreme-dual add rx-radio=wlan1 tx-radio=wlan2 rx-band=5ghz-turbo tx-band=5ghz-turbo rx-frequency=5540 tx-frequency=5620 /interface bridge port add interface=nstreme1 bridge=bridge1


Jeżeli skrypt jest w całości jest nie zrozumiały to poniżej znajduje się rozbicie na elementy.


/interface wireless set wlan1 country=poland - To polecenie wybiera tabelę częstotliwości obowiązującą w naszym kraju.

/interface enable wlan1 - To polecenie aktywuje kartę radiową wlan1

/interface enable wlan2 - To polecenie aktywuje kartę radiową wlan2

/interface bridge add - To polecenie powoduje dodanie bridge (mostu)

/interface bridge port add interface=ether1 bridge=bridge1 - To polecenie powoduje dodanie interfejsu enter1 do bridge1 (do mostu pierwszego).

/interface wireless nstreme-dual add rx-radio=wlan1 tx-radio=wlan2 rx-band=5ghz-turbo tx-band=5ghz-turbo rx-frequency=5540 tx-frequency=5620 - To polecenie powoduje przełączenie kart radiowych w tryb nstreme-2 z określeniem która karta działa w trybie wysłania (tx), a która działa w trybie odbioru (rx). "frequency" określa częstotliwość pracy.


Dla drugiego komputera


/interface wireless set wlan1 country=poland /interface enable wlan1 /interface enable wlan2 /interface bridge add /interface bridge port add interface=ether1 bridge=bridge1 /interface wireless set wlan1 mode=nstreme-dual-slave /interface wireless set wlan2 mode=nstreme-dual-slave /interface wireless nstreme-dual add rx-radio=wlan1 tx-radio=wlan2 rx-band=5ghz-turbo tx-band=5ghz-turbo rx-frequency=5620 tx-frequency=5540 /interface bridge port add interface=nstreme1 bridge=bridge1


Wpisując pierwsze polecenie otrzymujemy mac nstreme-dual który należy dopisać poleceniem drugim. Oczywiscie mac z pierwszego MT wpisujemy do drugiego MT i tak samo z drugiego do pierwszego.

1. /interface wireless nstreme-dual print

2. /interface wireless nstreme-dual set nstreme1 remote-mac=XXX disabled=no

Podziękowania dla "dejwid" z forum.osbridge.pl