modified on 28 gru 2010 at 13:18 ••• 6 730 views

Menedżer Użytkowników/Logi

Z MikroTik Wiki

Logi są zapisywane po otrzymaniu z router’a prośby o autoryzację lub uwierzytelnienie.

Można konfigurować oddzielnie dla każdego routera: które logi muszą być zapisane (Zobacz: HOWTO).

Dane Log’a zawierają:

  • Nazwę użytkownika. Może różnić się od tych zarejestrowanych w tablicy użytkownika
  • IP uzytkownika;
  • IP Host'a. IP Router'a;
  • Status;
  • Czas;
  • Opis;
  • Port NAS;
  • Typ portu NAS;
  • ID portu NAS;
  • ID sesji ACCT;
  • ID stacji zapytującej.

Log details


Więcej informacji o polach można znaleźć tutaj: Mikrotik RouterOS Radius client documentation, Supported RADIUS Attributes.

Wysyłanie logów do Syslog

Począwszy od wersji 3.24, dodana została opcja pomocy do wysyłania logów do SysLog By ją udostępnić:

1) Skonfiguruj router, dla którego mają być zapisywane logi: konto/niepowodzenie uwierzytelnienia/powodzenie (Zobacz: HOWTO);

2) W routerze skonfiguruj logi pisząc:

/system logging add topics=manager,account action=remote
/system logging action set remote target=remote remote=1.2.3.4:514

,gdzie 1.2.3.4 oraz 514 stanowią: adres IP oraz port UDP odległego hosta, które otrzymają logi.

3) Skonfiguruj swój zdalny host aby nasłuchiwał na porcie 514 (jakikolwiek inny port może być użyty, ale MUSI to być port UDP oraz MUSI być zgodny z wpisanym w akcji logowania systemu routera;

4) Sprawdź, czy logi są pomyślnie otrzymywane przez zdalny host:

4.1) Wygeneruj kilka logów poprzez kilkakrotne zalogowanie I wylogowanie używając użytkowników HotSpot/PPP;

4.2) Sprawdź Stronę logowania. Logi muszą pojawić się w niej. Logi są wysyłane do syslog tylko jeśli są zapisane w bazie danych Menadżera Użytkownika;

4.3) Sprawdź, czy logi są zdalnie otrzymywane. Jeśli używasz Linux, możesz użyć nc:

nc -l -u -p 514

, gdzie 514 jest używanym portem UDP. Może być tak, że wymagane są uprawnienia administratora aby włączyć nasłuchiwanie na porcie UDP. Alternatywą jest Wireshark – narzędzie wieloplatformowe służące zbieraniu pakietów w sieci. Zacznij nową sesję i wpisz:

udp port 514

w pole filtru. Powinieneś zobaczyć pojawianie się nadchodzących logów.

Format wiadomości Syslog

Logi występują w następującym formacie:

<user-ip>,<username>,<log-type>,<message>

, gdzie:

user-ip – IP użytkownika (NIE zaś IP routera!): cztery cyfry w zakresie 0-255, oddzielone przecinkami. 0.0.0.0 oznacza "pusty adres";

username – nazwa użytkownika lub adres MAC, kiedy używane jest MAC- uwierzytelnienie;

Typ log’a: ciąg znaków opisujący typ loga. Uwzględnia jedną z następujących wartości: "auth ok", "auth fail", "acct ok", "acct fail". „Fail” oznacza, że użytkownikowi nie powiodła się autoryzacja lub log był uszkodzony. Aby śledzić aktywność sesji użytkownika, tylko logi mające "auth ok" oraz "acct ok" muszą być brane pod uwagę.

message – zawiera wiadomość, opisującą błąd w przypadku niepowiedzenia. Może być pusty. Wiadomości SysLog mają ograniczony rozmiar, więc może się zdarzyć, że końcówka wiadomości zostanie ucięta.