modified on 25 lis 2009 at 08:41 ••• 34 231 views

MikroTik FAQ - Najczęściej zadawane pytania

Z MikroTik Wiki

Spis treści

Czym jest MikroTik Router OS

Co to jest MikroTik RouterOS?

MikroTik RouterOS jest routerowym systemem operacyjnym i oprogramowaniem, które przekształca zwyczajny komputer PC lub MikroTik RouterBOARD w router dedykowany.

Mogę przetestować MikroTik RouterOS przez zakupem licencji?

Tak, możesz pobrać wersję instalacyjną ze strony MikroTik'a i zainstalować na swoim routerze MikroTik. Router posiada pełną funkcjonalność bez wpisania klucza aktywacyjnego (licencyjnego) przez 24 godziny pracy. Jest to wystarczający czas na testy przez 3 dni po 8 godzin dziennie, jeśli będziesz wyłączał router po 8 godzinach pracy.

Jak mogę dostać klucz aktywacyjny?

Zarejestruj konto na stronie MikroTik (w prawym górnym rogu strony www.mikrotik.com). Można użyć karty kredytowej do zakupienia klucza.

Mogę użyć routera MikroTik do połączenia z dostawcą internetu przez T1, T2 lub inne szerokopasmowe łącze?

Tak, możesz zainstalować różne NIC obsługiwane przez RouterOS i uzyskać router brzegowy, router rdzenia, firewall, zarządcę pasmem, serwer VPN, bezprzewodowy punkt dostępowy, HotSpot i wiele więcej, w jednej maszynie. W manualu znajduje się lista obsługiwanych interfejsów.

Jak bardzo jest szybki?

Intel PC jest szybszy niż większość standardowych routerów. Nawet procesor 100MHz jest dosyć obciążony.

Jak bardzo to oprogramowanie jest podobne do routera Cisco?

Możesz zrobić prawie to samo co na standardowym routerze, za ułamek ceny routera, uzyskując dodatkowo elastyczność i możliwość aktualizacji, oraz łatwość w zarządzaniu i obsługiwaniu.

Jaki system operacyjny muszę mieć aby móc zainstalować MikroTik RouterOS?

Nie jest wymagany żaden system operacyjny. MikroTik RouterOS posiada swój własny system operacyjny i oprogramowanie. OS jest oparty na jądrze Linuksa i jest bardzo stabilny. Twój twardy dysk zostanie cały sformatowany podczas instalacji. Nie obsługuje dodatkowych nośników, tylko jeden PRIMARY MASTER HDD lub FlashDisk, oprócz pamięci podręcznej proxy WEB.

Jak bezpieczny jest router po konfiguracji?

Dostęp do routera jest zabezpieczony loginem i hasłem. Mogą zostać dodani dodatkowi użytkownicy, specyficzne uprawnienia można ustawić dla grup użytkowników. Zdalny dostęp do router może zostać ograniczony wg użytkownika, adresu IP. Filtr firewalla jest najprostszym sposobem na zabezpieczenie routera i sieci.

Logowanie i hasła

Jaka jest nazwa użytkownika i hasło, gdy loguje się na router pierwszy raz?

Nazwa to 'admin', nie ma hasła (naciśnij po prostu 'Enter'). Możesz zmienić hasło przy użyciu polecenia '/password'.

Jak mogę odzyskać utracone hasło?

Jeśli zapomniałeś hasła, nie ma możliwości odzyskania go. Musisz reinstalować router.

Po awarii sieci energetycznej router MikroTik nie włącza się

Jeśli nie wyłączyłeś routera, system plików nie został odmontowany właściwie. Podczas uruchamiania, RouterOS przeprowadzi sprawdzanie systemu plików. W zależności od rozmiaru HDD, może zająć do kilku minut. Nie przerywaj sprawdzania systemu plików! Może spowodować uniemożliwienie poprawnego działania systemu.

Jak moge uzyskać dostęp jeśli intefejs LAN został wyłączony?

Możesz dostać się do routera lokalnie (przy użyciu monitora i klawiatury) lub przez port szeregowy.

Licencje

Na ilu urządzeniach mogę zainstalować RouterOS mając jedną licencję?

Licencja jest na jedno urządzenie. Każdy router wymaga osobnej licencji.

Czy licencja traci kiedyś ważność?

Licencja nigdy nie traci ważności. Router będzie działać zawsze. Ale, licencja ma pewien ograniczony czas autualizacji - czas, w którym możesz zaktualizować oprogramowanie do nowszej wersji/ wyższego poziomu.

Jak mogę przeinstalować RouterOS bez utraty licencji? Musisz użyć CD, dyskietek lub Netinstall i zainstalowc RouterOS na dysku twardym, gdy poprzednia instalacja RouterOS jest nadal na tym dysku. Licencja przechowywana jest na HDD. Nie używaj narzędzi do formatowania lub partycjonowania ponieważ mogą usunąć Twoją licencję. Używaj tych samych ustawień BIOS dla swojego dysku.

Mogę używać swojej licencji na innym sprzęcie?

Tak, możesz używać innego sprzętu (płyta główna, interfejs sieciowy), ale powinieneś używać tego samego dysku twardego. Licencja przechowywana jest na HDD do czasu formatowania lub partycjonowania. Nie ma potrzeby reinstalacji systemu po zmianie sprzętu. Gdy kupujesz licencje, bądź świadom, że nie będziesz mógł użyć innego dysku twardego, niż ten na którym został zainstalowany RouterOS.

Co zrobić, gdy został uszkodzony dysk twardy z zainstalowanym RouterOS, muszę instalować nowy?

Jeśli kupiłeś licencję, musisz napisać to support[at]mikrotik.com i opisać swoją sytuację. Możemy wymagać, abyś przesłał nam uszkodzony twardy dysk jako dowód w przypadku otrzymania drugiego klucza.

Jeśli masz darmową wersję demo, nie ma potrzeby używania drugiego klucza. Zdobądź drugą licencję demo, lub kup podstawową licencję.

Więcej informacji znajdziesz tutaj: Wszystko o licencjach

Jak mogę wprowadzić nowy klucz?

Wpisując klucz przez konsolę/FTP:

  • zaimportuj odpowiedni plik przy użyciu polecenia '/system license import' (najpierw powinieneś umieścić go na serwerze FTP routera)

Wpisując klucz przez konsolę/Telnet:

  • użyj kopiuj/wklej aby wpisać klucz w oknie Telnetu (bez znaczenia w którym podmenu). Skopiuj cały klucz, łącznie z liniami "--BEGIN MIKROTIK SOFTWARE KEY--" i "--END MIKROTIK SOFTWARE KEY--"

Wpisując klucz przez Winbox:

  • użyj menu 'system->license' w Winboksie aby kleić i zaimportować klucz

Źle wpisałem ID software'u podczas zakupu klucza. Jak mogę to naprawić"

W Account Server wybierz 'work with keys', potem wybierz źle wpisany klucz, i naciśnij 'fix key'.

O wpisywaniu kluczy zajrzyj na tą stronę

Wpisywanie klucza licencyjnego RouterOS

Wszystkie pozostałe informacje można znaleźć tutaj

Wszystko o licencjach

Instalacja

Jaki jest największy rozmiar dysku twardego obsługiwany przez RouterOS?

MikroTik RouterOS obsługuje dyski większe niż 8GB (zazwyczaj do 120GB). Upewnij się, że BIOS płyty głównej obsługuje tak duże dyski.

Czy mogę uruchomić MikroTik RouterOS z dowolnego dysku w systemie?

Tak

Czy MikroTik RouterOS obsługuje wiele dysków twardych?

Drugi dysk przewidziany jest na pamięć podręczną www. Ta usługa została dodana w 2.8, starsze wersje nie obsługują wiele dysków twardych

Dlaczego instalacja z CD zatrzymuje się w pewnym momencie i nie chce się kontynuować?

Instalacja z CD nie działa poprawnie na niektórych płytach głównych. Spróbuj zrestartować komputer i rozpocząć instalację ponownie. Jeśli to nie pomoże, spróbuj przeprowadzić instalację na innym sprzęcie.

Uaktualnianie

Jak mogę zainstalować paczki z dodatkowymi elementami?

Musisz używać pliki pakietów (rozszerzenie .npk) z tą samą wersją co system. Użyj polecenia /system package print aby zobaczyć listę zainstalowanych pakietów. Sprawdź ilość wolnego miejsca na dysku Routera przy użyciu polecenia /system resource print przed wgrywaniem plików pakietów. Upewnij się, że masz przynajmniej 2MB wolnej przestrzeni na dysku po wgraniu pakietów!

Zgraj pakiety używając trybu binarnego ftp na routerze i wprowadź polecenie /system reboot aby wyłączyć i zrestartować router. Paczki są instalowane (aktualizowane) podczas wyłączania routera. Możesz monitować proces instalacji na ekranie monitora podłączonego do routera. Po restarcie, lista zainstalowanych pakietów dostępna jest w /system package print.

Jak mogę przeprowadzić aktualizację

Aby zaktualizować oprogramowanie, musisz ściągnąć najnowsze pliki z paczkami w naszej strony (paczka 'system' plus inne których potrzebujesz). Potem, połącz się z routerem przez ftp i wgraj nowe paczki.

Potem zrestartuj router poleceniem /system reboot. Więcej informacji: Upgrading_RouterOS

Zainstalowałem paczki z obsługą nowych interfejsów, ale odpowiedni interfejs nie jest wyświetlany na liście /interface print.

Musisz zdobyć (kupić) licencję odpowiedniego poziomu, lub zainstalować odpowiednią paczkę NPK dla tego interfejsu (na przykład paczkę 'wireless').

Jeśli zaktualizuję RouterOS to stracę swoją konfigurację systemu?

Nie, konfiguracja będzie nienaruszona podczas aktualizacji w tej samej rodzinie wersji. Gdy aktualizujesz rodzinę wersji (na przykład, z V2.5 do V2.6) możesz stracić konfigurację usług, w których nastąpiły największe zmiany. Na przykład, aktualizując z V2.4, powinieneś najpierw zaktualizować do najnowszej wersji 2.4.

Jak dużo miejsca na dysku potrzebuję przy aktualizacji na nowszą wersję

Potrzebujesz miejsce na paczkę systemową i dodatkowe pakiety, które aktualizujesz. Po wgraniu paczki z nową wersją na router, powinno zostać przynajmniej 2MB wolnego miejsca. Jeśli nie ma tyle miejsca, nie próbuj aktualizacji! Najpierw odinstaluj niepotrzebne pakiety, potem zaktualizuj pozostałe.

Przywracanie starszej wersji

Jak mogę przywrócić starszą wersję MikroTik RouterOS?

Możesz to zrobić reinstalując RouterOS dowolnym sposobem. Licencja zostanie zachowana na dysku, dopóki nie zostanie sformatowany/partycjonowany. Konfiguracja router zostanie utracona (możliwe jest zachowanie starej konfiguracji, ale może to spowodować niestabilność systemu, i nie jest polecane).

Drugim sposobem jest użycie polecenia /system package downgrade. Działa tylko gdy przywracasz do wersji 2.7.20 lub nowszej. Wgraj starsze pakiety na router przez FTP i użyj polecenia /system package downgrade.

Pytania dotyczące TCP/IP

Posiadam poprawnie działające dwie karty NIC w routerze MikroTik. Mogę pingować obie sieci z routera, ale nie mogę wysłać pinga z jednej sieci, przez router, do drugiej sieci i do internetu. Nie mam ustawionego firewall'a.

To jest typowy problem, gdy nie masz ustawionej trasy do Twojej głównej bramy internetowej. Ponieważ dodałeś nową sieć, potrzebujesz poinformować o tym swoją bramkę (Twojego ISP). Trasa powinna być dodana do nowej sieci. Ewentualnie, możesz 'ukryć' swoją sieć, poprzez zastosowanie maskarady (masquerade). Poświęć trochę czasu na przeczytanie Podręcznika Podstawowej Konfiguracji, gdzie ten problem jest opisany, razem z rozwiązaniem.

Tu jest przykład w jaki sposób zastosować maskaradę dla Twojej prywatnej sieci LAN:

[admin@MikroTik] ip firewall nat> add chain=srcnat action=masquerade out-interface=Public
[admin@MikroTik] ip firewall nat> print
Flags: X - disabled, I - invalid, D - dynamic 
 0   chain=srcnat out-interface=Public action=masquerade 

Jak mogę zmienić numer portu TCP dla usług telnet i http, jeśli nie chcę używać portów 23 i 80?

Możesz zmienić przydzielone porty w /ip service.

Gdy używam adresu/maski IP w formie 10.1.1.17/24 dla moich reguł filtrowania i kolejkowania, to te reguły nie działają.

Reguły 'nie działają', ponieważ nie dopasowują pakietów z powodu źle określonego adresu/maski. Poprawna forma powinna wyglądać tak:

 10.1.1.0/24 for the IP addresses in the range 10.1.1.0-10.1.1.255, or,
   10.1.1.17/32 for just one IP address 10.1.1.17. 

Potrzebuję skonfigurować klienta DHCP, ale nie ma menu '/ip dhcp-client'.

Usługa DHCP nie jest zawarta w pakiecie systemowym. Musisz zainstalować pakiet dhcp. Wgraj go na router i zrestartuj

Czy mogę statycznie powiązać IP do adresu MAC przez DHCP?

Tak, możesz dodać statyczne przydzielanie do listy przydziału w serwerze DHCP. Z założenia DHCP nie jest zabezpieczeniem i lepiej używać PPPoE dla uwierzytelniania i przydzielania adresów IP. Możesz dodatkowo wymagać od klienta, aby logował się z odpowiedniego adresu MAC.

W jaki sposób mogę zastosować maskaradę dla dwóch różnych podsieci przy użyciu dwóch różnych zewnętrznych adresów IP?

Użyj reguły z chain=srcnat action=nat w /ip firewall nat, określ wartość to-src-address. To będzie pierwszy zewnętrzny adres routera. Jeśli używasz action=masquerade, to wtedy nie jest brane pod uwagę to-src-address, ponieważ wtedy jest automatycznie podstawiany zewnętrzny adres serwera.

Nie mogę przeglądać niektórych stron gdy używam PPPoE

Użyj /ip firewall mangle aby zmienić MSS (maksymalny rozmiar segmentu) na wartość mniejszą o 40 bajtów niż MTU Twojego połączenia. Na przykład, jeśli szyfrujesz łącze PPPoE z MTU=1492, ustaw reguły znakowania jak poniżej:

/ ip firewall mangle 
add chain=forward protocol=tcp tcp-flags=syn action=change-mss new-mss=1448

Pytania dotyczące zarządzania pasmem

Czy mogę używać RouterOS jako most i urządzenie kształtujące ruch w jednej maszynie?

Tak. Możesz używać wszystkich usług zarządzania kolejkami. Ustaw kolejkę na interfejsie, na którym ruch obecnie opuszcza router, gdy przechodzi przez router. To nie jest interfejs mostkowy! Kolejka na interfejsie mostkowym działa tylko dla ruchu generowanego z routera.

Czy mogę ograniczyć pasmo w zależności od adresu MAC?

Dla pobierania:

1. connection-mark all packets from the MAC of each client with different marks
   for each client using action=passthrough:
   /ip firewall mangle add chain=prerouting src-mac-address=11:11:11:11:11:11 \
   action=mark-connection new-connection-mark=host11 passthrough=yes
 2. Remark these packets with flow-mark (again different flow-marks for each connection-marks):
   /ip firewall mangle add chain=prerouting connection-mark=host11 new-packet-mark=host11
 3. We can use these flow-marks in queue trees now.

To rozwiązanie powinno działać. Wadą jest to, że pierwszy pakiet każdego połączenia przychodzącego do tych klientów nie będzie znakowany.

Dla wysyłania:

 [admin@AP] ip firewall mangle> add chain=prerouting src-mac-address=11:11:11:11:11:11 \
   action=mark-packet new-packet-mark=upload

Pytania dotyczące sieci bezprzewodowej

Czy mogę tworzyć połączenie mostkowe na interfejsie wlanowym działającym w trybie stacji?

Nie, nie możesz.