modified on 21 lip 2010 at 09:54 ••• 4 156 views

Narzędzia/email

Z MikroTik Wiki

Dla RouterOS:
v3, v4, v5 +

Spis treści

Summary

E-mail tool is the utility that allows to send e-mails from the router. Tool can be used to send regular configuration backups and exports to network administrator.

Email tool uses only plain authentication and tls encryption. Other methods are not supported.


Properties

Sub-menu: /tool e-mail


This submenu allows to set smtp server that will be used.

Property Description
from (string; Default: <>) Name or email address that will be shown as receiver.
password (string; Default: "") Password used for authenticate to SMTP server.
server (IP:Port; Default: 0.0.0.0:25) SMTP server's IP address and port.
username (string; Default: "") Username used for authenticate to SMTP server.


Plik:Icon-note.png

Przypis: All server's configuration (if specified) can be overridden by send command.


Send

Email is sent using following command /tool e-mail send

Send command takes following parameters:

Property Description
body (string; Default: ) Actual body of the email message
file (string; Default: ) Name of the file that will be attached to the email. Only one file can be attached.
from (string; Default: ) Name or email address which will appear as sender. If not specified value from server's configuration is used.
password (string; Default: ) Password used to authenticate to SMTP server. If not specified value from server's configuration is used.
server (IP:Port; Default: ) Ip address and port of SMTP server. If not specified value from server's configuration is used.
subject (string; Default: ) Subject of the message.
tls (yes|no; Default: yes) Whether to use tls encryption or not.
to (string; Default: ) Destination email address
user (string; Default: ) Username used to authenticate to SMTP server. If not specified value from server's configuration is used.

Basic examples

This example will show how to send email with configuration export every 24hours.

1. Configure SMTP server

[admin@MikroTik] /tool e-mail> set server=10.1.1.1:25 from="router@mydomain.com"

2. Add new script named "export-send"

/export file=export
/tool e-mail send to="config@mydomain.com" subject="$[/system identity get name]  export) \ 
body="$[/system clock get date] configuration file" file=export.rsc

3. Add scheduler to run our script

/system scheduler
add on-event="export-send" start-time=00:00:00 interval=24h

[Powrót do menu strony]