modified on 10 sty 2008 at 10:26 ••• 22 498 views

Przekierowanie IP publicznego na IP wewnętrzne

Z MikroTik Wiki

Przeniesione z Forum OSBRIDGE.pl

Witam Mam pytanie, zawarte w samym temacie,na forum jest już udzielona odpowiedz ale u mnie to nie działa.Ale opisze dokładnie co i jak. Mam serwer postawiony na MT.On jest brama o ip 192.168.1.1 .I działa super.I teraz chciałem przydzielić komp. o IP 192.168.1.26 IP 83.17.xxx.xxx. Problem w tym ze jak powpisuje.

/ip address add address=83.17.225.53/29 interface=ether1 /ip firewall dst-nat add dst-address=83.17.225.53/32 action=nat to-dst-address=192.168.1.26 /ip firewall src-nat add src-address=192.168.1.26/32 action=nat to-src-address=83.17.225.53

To nie działa.Ale sprawa wygląda tak ze jak usunę z IP/Firewall/Source NAT masquerade to przekierowanie działa.Ale całą siec pada, tylko tylko ten 1 komp działa. Proszę o pomoc

pz daniel Opisze bardziel dokładnie:)

Adres serwera to 83.17.xxx.xxx brama 192.168.1.1

W IP Route mam coś takiego:

S 0.0.0.0/0 83.17.225.49 1 Ether1 DC 83.17.xxx.xx/29 0.0.0.0 83.17.xxx.xx 0 ether1 DC 192.168.1.0/24 0.0.0.0 192.168.1.1 0 ether2

Po pierwsze dodajesz:

/ip address add address=83.17.225.xx/29 interface=ether1

Ma to być adres nie używany czyli nie ten który ma MT (zewnętrzny). Po drugie sprawdź czy dobry interfejs ustawiłeś, jeśli tak to w ip route powinien pokazać sie ten adres. Po trzecie nie daje sie /ip firewall src-nat add src-address=192.168.1.26/32 action=nat to-src-address=83.17.225.53 a jeśli już musisz to dać to sprawdzaj dokładnie dla jakich interfejsów przypisujesz adresy. Pewnie dlatego wywala ci siec.

Spróbuj dodać : Kod:

ip firewall dst-nat add dst-address=83.17.255.xx/32 protocol=tcp action=nat to-dst-address=192.168.1.26

ip firewall nat add chain=dstnat dst-address=public ip action=dst-nat \ to-addresses=local ip to-ports=0-65535 comment="Zewnetrzne IP dla X" disabled=no

w /ip adress dodajesz publiczny najlepiej do interfejsu ktory jest odpowiedzialny za połączenie z netem

z maska 29 (83.18.46.../29) (musi być inny niż ten na którym masz połączenie!!! najlepiej następny z puli)


wchodzisz w ip firewall nat klikasz na czerwony PLUS chain dsnat dst. address wpisujesz ten co wpisałeś w ip adress (ten nowy z puli ale już bez maski)

w zakładce action

action dstnat to address (twoj ip z sieci lokalnej) to ports 0-65535

później dajesz ok dodajesz znów regułkę w /ip firewall nat klikając na czerwony plus

chain srcnat src address (twoj ip z locala) w zakładce action action srcnat to address (ip z puli od tpsa ten co w ip address ale ten nowy! ) to ports 65535

i niech ktoś mi nie pisze ze to nie działa bo już bardziej łopatologicznie sie nie da tego opisać.

u mnie na 2.9.2 wygląda to mniej więcej tak:


chain=dstnat in-interface=Public src-address=0.0.0.0/0 dst-address=xxx.xxx.xxx.xxx protocol=udp dst-port=4672 action=dst-nat to-addresses=192.168.0.5 to-ports=0-65535

chain=dstnat in-interface=Public src-address=0.0.0.0/0 dst-address=xxx.xxx.xxx.xxx protocol=tcp dst-port=4662 action=dst-nat to-addresses=192.168.0.5 to-ports=0-65535


Gdzie xxx.xxx.xxx.xxx to zewnętrzny adres IP ja mam w ten sposób przekierowanego osła i po połączeniu pojawia się z "High ID"