modified on 1 lip 2010 at 11:20 ••• 15 556 views

Przepływ Ruchu

Z MikroTik Wiki

Spis treści

Informacje ogólne

Specyfikacja

Wymagane pakiety: system

Wymagane licencje: level1

Poziom Home menu: /ip traffic-flow

Wykorzystanie sprzętowe: nieznaczne

Powiązane dokumenty

  • Cisco NetFlow
  • NTop
  • Integrating NTop with NetFlow

Opis

MikroTik Traffic-Flow jest systemem, który dostarcza informacje statystyczne o pakietach przepływających przez router. Poza tym administratorzy systemu mogą rozpoznawać różne problemy, które pojawiają się w sieci. Z pomocą Traffic-Flow możliwa jest analiza i optymalizacja działania całej sieci. Traffic-Flow jest kompatybilny z Cisco NetFlow i może być używany z różnymi narzędziami zaprojektowanymi na NetFlow Cisco.

Traffic-Flow obsługuje następujące formaty NetFlow:

  • version 1 - pierwsza wersja formatu danych NetFLow, nie używaj tego, chyba że musisz
  • version 5 - jak wersja 1, lecz dodatkowo ma BGP AS i informacje o numerze sekwencji przepływu
  • version 9 - nowy format, który może być rozszerzony o nowe pola i typy rekordów

Konfiguracja

Opis

Ten rozdział opisuje podstawową konfigurację Traffic-Flow

Opis Własności

active-flow-timeout (time; domyślnie: 30m) - maksymalny czas życia strumienia

cache-entries (1k | 2k | 4k | 8k | 16k | 32k | 64k | 128k | 256k | 512k; domyślnie: 1k) - liczba strumieni, które mogą być umieszczone jednocześnie w pamięci routera

enabled (yes | no) - czy włączyć usługę traffic-flow, czy nie

inactive-flow-timeout (time; domyślnie: 15s) - jak długo utrzymać aktywny strumień, gdy jest nieaktywny

interfaces (name) - nazwy tych interfejsów, które będą użyte do zbierania statystyk dla ruchu. Aby określić więcej niż jeden interfejs, oddziel je przecinkiem.

Cel Przepływu

Poziom Home menu: /ip traffic-flow target

Opis

Celami Traffic-Flow określamy te hosty, które zbierają informacje o przepływie z routera.

Opis Własności

address (IP addressport) - adres IP i port UDP hosta, który odbiera pakiety ze statystykami Traffic-Flow z routera

v9-template-refresh (integer; domyślnie: 20) - liczba pakietów, po których szablon jest wysyłany do hosta (tylko w wersji 9 NetFlow)

v9-template-timeout - czas, poi jakim ma być wysłany szablon, jeśli jeszcze nie został wysłany

version (1 | 5 | 9) - z jakiej wersji NetFlow korzystać

Przykłady Aplikacji

Przykład Traffic-Flow

Przykład ten pokazuje, jak skonfigurować Traffic-Flow na routerze

1. Uruchom Traffic-Flow na routerze:

[admin@MikroTik] ip traffic-flow> set enabled=yes
[admin@MikroTik] ip traffic-flow> print
                enabled: yes
             interfaces: all
          cache-entries: 1k
    active-flow-timeout: 30m
  inactive-flow-timeout: 15s
[admin@MikroTik] ip traffic-flow>

2. Określ adresy IP i porty hostów, z których będą otrzymywane pakiety Traffic-Flow:

[admin@MikroTik] ip traffic-flow target> add address=192.168.0.2:2055 \
\... version=9
[admin@MikroTik] ip traffic-flow target> print
Flags: X - disabled
 #   ADDRESS                 VERSION
 0   192.168.0.2:2055        9
[admin@MikroTik] ip traffic-flow target>

Teraz router zaczyna wysyłać pakiety z informacjami o przepływającym strumieniu.

Niektóre zrzuty ekranów z programu NTop, które zawierają informacje o przepływie z routera i wyświetlają je na ładnych wykresach i statystykach. Na przykład, gdzie odnotowano następujący przepływ:

Grafika: host information.jpg

Trzy górne hosty każdej minuty wysyłały i odbierały:

Grafika:network matrix.jpg

Cała sieć w każdej minucie:

Grafika:wykres 1 minute.jpg

Wykorzystanie ruchu przez każdy protokół:

Grafika:global distribution.jpg