modified on 5 maj 2011 at 08:00 ••• 31 441 views

RouterOS FAQ

Z MikroTik Wiki

Spis treści

Co to jest MikroTik RouterOS™?

Co robi MikroTik RouterOS™?
MikroTik RouterOS™ to router w postaci systemu operacjnego i oprogramowania który to zamienia zwykły komputer klasy PC lub urządzenie MikroTik RouterBOARD™ na dedykowany router.
Jakie funkcje oferuje RouterOS™?
Lista oferowanych funkcji RouterOS
Czy mogę przetestować funkcjonalność MikroTik RouterOS™ zanim dokonam zakupu licencji?
Tak, możesz pobrać obraz płyty MikroTik's ze strony i zainstalować go na Swojej płycie routera MikroTik. Router jest w pełni funkcjonalny przez 24 godziny czasu pracy bez potrzeby posiadania klucza licencji. Jest to wystarczający czas, aby przetestować router przez 3 dni korzystając z niego 8 godzin dziennie.
Skąd mogę pobrać klucz licencji?
Create an account na stronie MikroTik (w prawym górnym rogu strony www.mikrotik.com). Możesz użyć karty kredytowej, aby zapłacić za klucz.
Czy mogę użyć routera MikroTik do połączenia się z usługodawcą poprzez T1, T3, lub poprzez inne szybkie łącze?
Tak, możesz zainstalować wspierane przez MikroTik RouterOS™ karty sieciowe i uzyskać router brzegowy, firewall,kontroler wykorzystywania pasma, serwer VPN, punkt dostępu, HotSpot i o wiele więcej w jednym. Proszę zobacz Specification Sheet oraz Manual w celu przeglądu wspieranych urządzeń!
Jak szybko router może pracować?
Na komputerach klasy PC w większości przypadków router działa szybcie i nawet 100MHz mocy procesora wystarcza do zwiększenia wydajności.
Jak RouterOS plasuje się w porównaniu z routerami Cisco?
Możesz zrobić niemalże wszystko a koszt posiadania elastyczności w aktualizacji, łatwość zarządzania i konserwacji jest wielokrotnieniższy niż routerow CISCO.
Jaki system operacyjny potrzebuję do instalacji MikroTik RouterOS™?
Żaden system operacyjny nie jest potrzebny, gdyż MikroTik RouterOS™ sam jest samodzielnym systemem operacyjnym. Ten system bazuje na stabilnym jądrze Linuksa. Twója pamięć masowa zostaje całkowicie wymazana poprzez proces instalacji. System obsługuje tylko pierwszy główny dysk twardy (PRIMARY MASTER HDD) lub FlashDisk, lecz nie dotyczy to proxy cache dla sieci WEB.
Jak domyślnie zabezpieczony jest router po instalacji?
Dostęp do routera jest chroniony przez nazwę urzytkownika i hasło. Istnieje możliwość dodania użytkowników a ich prawa mogą być rególowane poprzez politykę grup urzytkownikow. Zdalny dostęp może być zabroniony na podstawie: nazwy użytkownika i IP. Reguły firewalla Firewall filtering są najprostszym sposobem zabezpieczenia routera i sieci.

Instalacja

Jak można zainstalować RouterOS?
RouterOS może być zainstalowany z płyty instalacyjnej lub NetInstall.
Jak duży dysk twardy można używać do MikroTik RouterOS ™?
MikroTik RouterOS™ obsługuje dyski większe niż 8GB (zazwyczaj do 120GB), ale upewnij się, że BIOS płyty głównej routera jest w stanie wesprzeć takie duże dyski.
Czy mogę uruchomić MikroTik RouterOS™ z dowolnego dysku w systemie?
Tak
Czy jest wsparcie dla wielu dysków twardych w MikroTik RouterOS™?
Wszystkie kolejne napędy obsługują pamięć podręczą WWW (cache). To wsparcie zostało dodane w wersji 2.8, starsze wersje nie obsługują wielu dysków twardych.
Dlaczego płyta instalacyjna w pewnym momencie zatrzymuje się i nie przechodzi "przez całą drogę"?
Dysk instalacyjny CD nie działa poprawnie na niektórych płytach głównych. Spróbuj ponownie uruchomić komputer i uruchomić instalację ponownie. Jeśli to nie pomoże, spróbuj użyć innego sprzętu.

Logowanie się i hasła

Jaka jest nazwa użytkownika i hasło podczas pierwszego logowania się?
Nazwa użytkownika to 'admin' a hasła domyślnie nie ma (porostu naciśnij 'Enter'). Możesz zmienić hasło używając komendy '/password'.
Jak mogę odzyskać utracone hasło?
Jeśli stracisz hasło to nie ma możliwości jego odzyskania. Musisz reinstalować router [1].
Podczas braku zasilania MikroTik nie chce się ponownie uruchomić.
Jeśli nie zamknął się router poprawnie, system plików nie został zamontowany prawidłowo. Podczas uruchamiania RouterOS ™ dokona sprawdzenia systemu plików. W zależności od rozmiaru dysku twardego, może upłynąć kilka minut. Nie przerywaj sprawdzania systemu plików! Może to doprowadzić do nieprawidłowego działania routera.
Jak mogę dostać się do routera, jeśli interfejs LAN został wyłączony?
Można dokonać tego lokalnie (podpinając monitor i klawiaturę) lub poprzez konsolę.

Problemy licencyjne

Ile instalacji MikroTik RouterOS™ może znajdować się na licencji?
Licencja dotyczy instalacji RouterOS™. Pozostałe instalacje wymagają oddzielych licencji.
Kiedy licencja wygasa?
Licencja nigdy nie wygasa i jest na wieki. Jedynym ograniczeniem jest które wersje możesz aktualizować. Dla przykładu, jeśli napisane jest "Uaktualnienie do 4.x" to oznacza, że możesz używać wszystkie uaktualnienia dla wersji 4, ale już nie dla wersji 5, co nie jest powiedziane, że musisz zostać przy wersji 4 do końca Swych dni.
Jak ponownie zainstalować oprogramowanie MikroTik RouterOS ™ bez utraty licencji?
Musisz użyć płyty CD, dyskieteki lub instalacji NetInstall i zainstalować MikroTik RouterOS ™ na dysku twardym z poprzednią nienaruszoną instalacją MikroTik RouterOS™. Licencja jest przechowywane na dysku twardym. Nie stosować formatowania lub narzędzi do podziału dysku takich jak fdisk, gdyż będzie wtedy usunięty klucz licencji. Użyj tego samego (jak i podczas instalacji) ustawieniach dysku twardego systemu BIOS!
Czy mogę używać mojej licencji MikroTik RouterOS™ na innym sprzęcie?
Tak, możesz użyć innego sprzętu (płyty głównej, karty sieciowej), ale powinieneś pozostać przy tym samym dysku. Licencja przechowywana jest na dysku twardym aż do momentu sformatowania go lub użycia fdisku do zmian w strukturze dysku. Po wymianie sprzętu można ponownie zainstalować oprogramowanie, lecz nie jest to wymagane. W przypadku płatności za licencję, należy pamiętać, że nie może być używany na innym dysk, niż ten, na którym zostało zainstalowane oprogramowanie.
Przeniesieniu licencji na inny dysk twardy kosztuje 10$. Skontaktuj się ze wsparciem w celu ustalenia szczegółów.
Co zrobić, gdy mój dysk twardy z MikroTik RouterOS™ jest uszkodzony i muszę zainstalować jeszcze jeden?
Jeśli zapłaciłeś za licencję, musisz napisać do wsparcia support[at]mikrotik.com i opisać całą sytuację. Możemy prosić Cię o przesłanie uszkodzonego dysku twardego do nas jako dowód przed wydaniem klucza wymiany (zastępczego).
Co się stanie jeśli mój sprzęt ponownie ulegnie awarii, a ja stracę klucz zastępczy?
Ten sam proces stosowany jest jak wyżej, ale tym razem, musimy posiadać fizyczny dowód, że nie miał w rzeczywistości inny incydent.
Jeśli masz na wolnej licencji demo, żaden klucz zastępczy nie może być wydany. Proszę uzyskać inną licencję demo, lub zakupić licencję. Więcej informacji Wszystko_o_licencjach.
Jak mogę wpisać nowy klucz produktu?
Możesz posłużyć się konsolą/FTP:
  • zaimportuj załączony plik komendą '/system license import' (powinieneś przesłać plik na router na serwer FTP)
Wpisać klucz poprzez konsolę/połączenie telnet:
  • użyj metody kopiuj/wklej wstawiając klucz w okno konsoli telnet (nie gra roli w którym miejcu). Upewnij się, aby wklejony klucz był ciągiem znaków rozpoczynającym się "--BEGIN MIKROTIK SOFTWARE KEY--" i kończącym "--END MIKROTIK SOFTWARE KEY--".
Wpisywanie klucza przy pomocy Winbox:
  • Użyj menu 'system -> license' w celu wklejenia lub zaimportowania klucza.
Mam nieprawidłowo wpisane ID oprogramowania, kiedy zakupywałem klucz programowania. Jak mogę to naprawić?
W Account Server wybierz "pracy za pomocą klawiszy" ("work with keys"), a następnie wybierz nieprawidłowo wpisany klucz, a następnie wybierz "napraw klucz" ("fix key").
Na temat wprowadzania kluczy zobacz stronę
Wprowadzanie_klucza_licencji_RouterOS
Wszystkie inne informacje na temat kluczy licencji można znaleźć na stronie
Wszystko_o_licencjach

Aktualizacja

Jak można zainstalować dodatkowe pakiety funkcji?
Musisz użyć tej samej wersji pakietu plików (rozszerzenie. NPK) jak pakiet systemu. Użyj komendy /system package print, aby wyświetlić listę zainstalowanych pakietów. Sprawdź ilość wolnego miejsca na HDD za pomocą /system resource print przed przesłaniem plików z pakietami. Upewnij się, że jest co najmniej 2 MB wolnego miejsca na dysku na routerze po przesłaniu plików!
Ściągnij pakiet plików za pomocą ftp w trybie BINARY do routera i wydaj polecenie /system reboot, aby wyłączyć i ponownie uruchomić router. Pakiety są instalowane (aktualizowane) podczas zamykania. Możesz monitorować proces instalacji na ekranie monitora podłączonego do routera. Po restarcie, zainstalowane pakiety pokazywane po komendzie /system package print.
Jak mogę aktualizować oprogramowanie?
Aby aktualizować oprogramowanie należy pobrać ostatnie pakiety (*.npk) ze strony www (pakiet 'system' oraz inne Tobie potrzebne). Następnie połącz się poprzez FTP i prześlij nowe pakiety używając trybu binarego.
Po zakończeniu się poprzedniej operacji wykonaj ponowne uruchomienie routera używając komendy /system reboot.
Więcej informacji można uzyskać na stronie: Upgradeowanie_RouterOS
Zainstalowałem dodatkowe pakiety, lecz nie mam ich na liści po wydaniu polecenia /interface print.
Musisz posiadać/uzyskać (kupić) odpowiednią licencję lub zainstalować pakiety NPK dla odpowiedniego interfejsu.
Jeśli aktualizuje RouterOS stracę moją konfigurację?
Nie, konfiguracja zostaje zachowana w ramach jednej rodzinnej (np: v3, v4, v5 )wersji. Podczas uaktualniania wersji rodzinnej (np. V2.5 do V2.6) możesz stracić konfigurację niektórych funkcji, które mają poważne zmiany. Na przykład podczas aktualizacji V2.4, należy uaktualnić do ostatniej wersji 2.4 w pierwszej kolejności.
Ile potrzebuje wolnej przestrzeni dyskowej, gdy potrzebuję aktualizować do wyższej wersji?
Musisz mieć miejsce na dysku dla pakiety systemowe i dodatkowe, które chcesz aktualizować. Po wgraniu nowych wersji pakietów do routera powinieneś mieć co najmniej 2MB wolnego miejsca na dysku. Jeśli tak nie będzie, nie próbuj zrobić aktualizacji! Odinstaluj zbędne pakiety w pierwszej kolejności, a następnie aktualizuj pozostałe.

Aktualizacja do wersji niższej

Jak mogę MikroTik RouterOS™ aktualizować do niższej wersji?
Możesz obniżyć wersję RouterOS™ przez ponowną instalację z dowolnego nośnika. Licencji na oprogramowanie będzie przechowywana na dysku twardym o ile dysk nie zostanie ponownie podzielony/sformatowany. Konfiguracja routera zostanie utracona (możliwe jest zapisanie starej konfiguracji, ale opcja jest nieprzewidywalna i nie jest polecana).
Innym sposobem jest użycie polecenia /system package downgrade. Funkcja ta działa tylko, jeśli przejście do niższej wersji (eng. downgrade) nie jest dalsze jak do 2.7.20. Prześlij starsze pakiety do routera za pośrednictwem protokołu FTP, a następnie wydaj polecenie /system package downgrade.

Problemy z TCP/IP

Mam dwie karty sieciowe (NIC) w routerze MikroTik i działają prawidłowo. Mogę przesłać pakiety polecenia ping do każdej z tych sieci, lecz nie mam takiej możliwości z jednej sieci do drugiej lub też do internetu. Nie mam konfiguracji firewall.
Jest to typowy problem, gdy nie masz routingu ustawionego dla w głównej bramy internetowej. Skoro wprowadziłeś nową sieć, musisz "powiedzieć" o tym głównej bramie (ISP). Trasa (eng. routing) powinna być dodana do nowej sieci. Alternatywnie można 'ukryć' nowe sieci poprzez maskarade, aby uzyskać dostęp do Internetu. Proszę poświęcić chwilkę czasu na zapoznanie się z podstawową dokumentacją a problem jest tam opisany i rozwiązanie jest tam przedstawione.
Jest to przykład maskarady Twojej sieci LAN:
[admin@MikroTik] ip firewall nat> add chain=srcnat action=masquerade out-interface=Public
[admin@MikroTik] ip firewall nat> print
Flags: X - disabled, I - invalid, D - dynamic 
 0   chain=srcnat out-interface=Public action=masquerade 
Jak mogę zmienić numer portu TCP dla usług telnet lub http, jeśli nie chce korzystać odpowiednio z portów 23 i 80?
Można zmienić porty przydzielone poprzez komendę /ip service.
Kiedy używam IP/maska ​​w postaci 10.1.1.17/24 dla mojego filtrowania lub kolejkowanie zasad, to nie działają.
Zasada 'nie działa', ponieważ nie pasuje do pakietów ze względu na błędnie podany adres/maskę​​. Poprawna forma to:
   10.1.1.0/24 dla adresu IP na przestrzeni 10.1.1.0-10.1.1.255, lub
   10.1.1.17/32 dla jednego adresu IP 10.1.1.17. 
Chcę skonfigurować klienta DHCP, ale nie ma menu '/ip dhcp-client'.
Funkcja DHCP nie jest zawarta w pakiecie oprogramowania systemowego. Musisz zainstalować pakiet dhcp. Wyślij pakiet do routera i uruchom ponownie!
Czy mogę powiązać statyczne adresy IP do adresów MAC przez DHCP?
Tak, można dodać statyczne adresy IP do listy serwera DHCP. Jednakże, serwer DHCP jest domyślnie nie do końca zadowolony z takiego rozwiązania i lepiej jest używać PPPoE do uwierzytelniania użytkowników i w ten sposób rozdawać adresy IP. Nie można zażądać od użytkownika logowania się z określonego adresu MAC.
Jak mogę dokonać maskarady dwóch różnych podsieci przy użyciu dwóch różnych zewnętrznych adresów IP dla nich?
Zastosuj zasady /ip firewall nat z akcją chain=srcnat action=nat oraz określ wartość dla to-src-address, który to powinien on być jednym z zewnętrznych adresów routera. Jeśli korzystasz z action=masquerade, to to-src-address nie jest brany pod uwagę, ponieważ jest zastąpiony automatycznie przez zewnętrzny adres routera.
Nie mogę przeglądać niektórych stron podczas korzystania z PPPoE.
Zastosuj /ip firewall mangle, aby zmienić MSS (maximum segment size) o 40 bajtów mniej niż MTU połączenia. Na przykład, jeśli masz szyfrowane łącze PPPoE z MTU=1492, ustaw zasady mangle w następujący sposób:
 / ip firewall mangle 
 add chain=forward protocol=tcp tcp-flags=syn action=change-mss tcp-mss=!0-1448 new-mss=1448

Pytania o menadzer przepustowości łącza

Jak mogę kontrolować przepustowość (kształtować szerokość pasma) w trybie połączenia mostowego (eng. bridge)?
W ustawienia mostu włącz 'use-ip-firewall'.
Czy mogę używać MikroTik jako Most i kontroler ruchu w jednym urządzeniu?
Tak. Można korzystać ze wszystkich funkcji zarządzania kolejkami. Ustaw kolejkę do interfejsu, gdzie ruch jest faktycznie kierowany na router, gdy przechodzi przez router. To nie jest interfejs mostu! Kolejka na interfejsie mostu jest zaangażowana tylko dla ruchu generowanego przez router.
Czy można ograniczyć szerokość pasma na podstawie adresów MAC?
Do pobrania:

(eng.)

   1. connection-mark all packets from the MAC of each client with different marks
   for each client using action=passthrough:
   /ip firewall mangle add chain=prerouting src-mac-address=11:11:11:11:11:11 \
   action=mark-connection new-connection-mark=host11 passthrough=yes
   2. Remark these packets with flow-mark (again different flow-marks for each connection-marks):
   /ip firewall mangle add chain=prerouting connection-mark=host11 new-packet-mark=host11
   3. We can use these flow-marks in queue trees now.
Powyższa instrukcja powinna działać, lecz posiada w sobie wadę, która mówi, że pierwszy pakiet każdego połączenia przeznaczony dla klientów, nie będzie brany pod uwagę.
Do przesłania:
   [admin@AP] ip firewall mangle> add chain=prerouting src-mac-address=11:11:11:11:11:11 \
   action=mark-packet new-packet-mark=upload

Pytania o sieci bezprzewodowe

Czy mogę mostkować interfejs wlan w trybie station?
Nie, nie możesz.

Pytania o BGP

BGP (ang. Border Gateway Protocol) protokół bramy brzegowej.

Zobacz BGP HowTo i FAQ