modified on 21 lip 2010 at 10:33 ••• 4 977 views

Routing/BFD

Z MikroTik Wiki

Spis treści

Summary

Bidirectional Forwarding Detection (BFD) is a protocol intended to detect faults in the bidirectional path between two forwarding engines, including physical interfaces, sub-interfaces, data link(s), and to the extent possible the forwarding engines themselves, with potentially very low latency. It operates independently of media, data protocols, and routing protocols.

BFD is basically a hello protocol for checking bidirectional neighbor reachability. It provides sub-second link failure detection support. BFD is not routing protocol specific, unlike protocol hello timers or such.

Requirements

RouterOS 4.4 or newer with routing package installed.

Features supported

  • asynchronous mode [1]
  • BFD timer and detection multiplier configuration per interface;
  • enabling BFD for OSPF interfaces
  • enabling BFD for BGP peers
  • single hop IPv4 and IPv6 transport [2]
  • multihop IPv4 and IPv6 transport [3]

Features not yet supported

  • echo function
  • on-demand mode
  • authentication

Configuration

BFD configuration should be added in different places as required

OSPF

/routing ospf interface add interface=all use-bfd=yes

BGP

/routing bgp peer add remote-address=x.x.x.x remote-as=xxxxx use-bfd=yes

BFD timer configuration

/routing bfd interface

BFD neighbor status

/routing bfd neighbor

Interoperability

For interoperability with Cisco make sure to disable echo mode (it is enabled on Cisco by default), since it's not supported on MT.

To do that, on Cisco in interface configuration mode type:

no bfd echo