modified on 11 kwi 2013 at 10:38 ••• 28 269 views

Serwer i Klient NTP

Z MikroTik Wiki

Spis treści

Informacje Ogólne

Wprowadzenie

Protokół NTP umożliwia synchronizację czasu na komputerach w sieci. Dobrze jest, gdy dostępne jest połączenie internetowe i lokalny serwer NTP jest synchronizowany z odpowiednim źródłem czasu. Lista publicznych serwerów NTP dostępna jest pod adresem [1]. Wszystko co potrzebujesz, to klient NTP, więc możesz używać klienta SNTP ze względu na jego małe wymagania systemowe i małe zużycie pamięci. Klient jest zawarty w pakiecie system i jest aktywny, gdy pakiet ntp jest wyłączony lub odinstalowany.

Specyfikacja

Wymagany pakiet: system

Wymagana licencja: Level1

Poziom menu: /system ntp

Standardy i technologie: NTP wersja 3 (RFC 1305)

Wykorzystanie sprzętu: nieznaczne

Opis

Network Time Protocol (NTP) używany jest do synchronizacji czasu z serwerami NTP, w sieci. MikroTik RouterOS zapewnia oba - klient NTP jak i serwer NTP.

Serwer NTP nasłuchuje na porcie UDP 123

Klient NTP synchronizuje lokalny zegra z innym źródłem czasu (serwerem NTP). Są 4 tryby, w których klient NTP może pracować:

* unicast (Klient/Serwer) - klient NTP łączy się z określonym serwerem NTP. Adres IP serwera NTP musi być ustawiony w parametrach ntp-serwer i/lub second-ntp-serwer'. Najpierw klient przeprowadza synchronizację z serwerem NTP. Następnie klient okresowo (64..1024 s) wysyła żądanie czasu do serwera NTP. Tryb unicast jest jedynym, który używa parametrów ntp-serwer i second-ntp-serwer.

* broadcast - Klient NTP odbiera wiadomości broadcastowe wysłane przez dowolny serwer NTP. Po otrzymaniu pierwszego pakietu, klient synchronizuje lokalny zegar używając trybu unicastowego, po czym nie wysyła pakietów do tego serwera NTP, lecz oczekuje na kolejne wiadomości broadcastowe.

* multicast - działa tak samo jak w trybie broadcast, ale zamiast nasłuchiwać wiadomości broadcastowych (adres IP 255.255.255.255) nasłuchuje wiadomości multicastowych (adres IP 224.0.1.1).

* manycast - tak jak tryb unicast ale wtedy, gdy nie jest znany adres IP serwera NTP. Aby wykryć serwer NTP, klient wysyła wiadomości multicastowe (IP 239.192.1.1). Jeżeli serwer NTP nasłuchuje tych wiadomości multicastowych (tryb manycast jest włączony), odpowiada. Po otrzymaniu przez klienta wiadomości, klient odpowiada, wchodzi w tryb unicastowy i synchronizuje się z tym serwerem NTP. Równolegle z tym klient kontynuuje wyszukiwanie kolejnych serwerów NTP przez okresowe wysyłanie wiadomości multicastowych.

Klient

Poziom menu: /system ntp client

Opis własności

enabled (yes | no; default: no) - czy klient NTP jest włączony

mode (unicast | broadcast | multicast | manycast; default: unicast) - tryb klienta NTP

primary-ntp (IP address; default: 0.0.0.0) - adres IP podstawowego serwera NTP

secondary-ntp (IP address; default: 0.0.0.0) - adres IP alternatywnego serwera NTP

status (read-only: text) - status klienta NTP:

  • stopped - NTP jest wyłączone
  • error - wystąpił wewnętrzny błąd podczas uruchamiania usługi NTP (można spróbować zrestartować usługę NTP)
  • started - usługa klienta NTP jest włączona, ale nie znaleziono jeszcze serwera NTP
  • failed - serwer NTP wysłał niepoprawną odpowiedź do klienta NTP (serwer NTP nie jest zsynchronizowany z innymi źródłami czasu)
  • reached - nawiązano połączenie z serwerem NTP. Następuje porównywanie zegar lokalny z zegarem serwera NTP (czas trwania tej fazy - ok 30s)
  • timeset - czas lokalny zmieniony na czas serwera NTP (czas trwania tej fazy - ok 30s)
  • synchronized - zegar lokalny jest zsynchronizowany z zegarem serwera NTP. Serwer NTP jest włączony
  • using-local-clock - używany jest zegar lokalny jako źródło czasu (serwer jest włączony, a klient wyłączony)

Przykład

Włączenie synchronizacji klienta NTP z serwerem 159.148.60.2 :

[admin@MikroTik] system ntp client> set enabled=yes primary-ntp=159.148.60.2
[admin@MikroTik] system ntp client> print
          enabled: yes
             mode: unicast
      primary-ntp: 159.148.60.2
    secondary-ntp: 0.0.0.0
           status: synchronized
[admin@MikroTik] system ntp client>

Serwer

Poziom menu: /system ntp serwer

Opis własnośći

broadcast (yes | no; default: no) - określa, czy wiadomośc broadcastowa NTP będzie wysyłana co 64s na 255.255.255.255

enabled (yes | no; default: no) - określa, czy serwer NTP jest włączony

manycast (yes | no; default: yes) - określa, czy serwer NTP nasłuchuje wiadomości multicastowych wysyłanych na 239.192.1.1 i odpowiada na nie

multicast (yes | no; default: no) - określa, czy wiadomości multicastowe NTP są wysyłane co 64s na 224.0.1.1

Uwagi

Serwer NTP jest aktywny tylko gdy lokalny klient NTP znajduje się w stanie synchronized lub using-local-clock.

Jeżeli serwer NTP jest wyłączony, wszystkie zapytania NTP są ignorowane

Jeżeli serwer NTP jest włączony, wszystkie zapytania o czas są obsługiwane

UWAGA! Używanie trybów broadcast, multicast i manycast jest niebezpieczne! Intruz (lub zwykły użytkownik) może ustawić swój własny serwer NTP. Jeśli ten nowy serwer zostanie wybrany jako źródło czasu, użytkownik będzie mógł zmienić czas Twojego serwera.

Przykład

Włączenie serwera NTP i odpowiadanie wyłącznie na zapytania unicastowe:

[admin@MikroTik] system ntp server> set manycast=no enabled=yes
[admin@MikroTik] system ntp server> print
      enabled: yes
    broadcast: no
    multicast: no
     manycast: no
[admin@MikroTik] system ntp server>