modified on 21 lip 2010 at 09:09 ••• 4 263 views

Store

Z MikroTik Wiki

Dla RouterOS:
v3, v4

Store manages storage devices used by RouterOS various facilities. For example Webproxy and User Manager (and eventually also the Dude) could use external storage devices to store their files and databases. This is especially useful for RouterBOARD devices with SD/CF slots - as the built-in storage is quite small, an external drive comes in very handy when you want a big User Manager database.

Image:Store.png

You can add as many external or secondary drives as you want, and select any number of them for each of the mentioned feature use. For example User Manager could be used on 3 disks, one of them would be the active database, and the rest would be backups. You can then add a fourth disk, copy the active data to it - unplug it - and move to another server, to keep using the actual database.

This means migration and backup made easy!

Creating a Store instance

[normis@demo.mt.lv] /store> print
Flags: X - disabled, A - active 
 #   NAME                      TYPE                    DISK                    STATUS    
 0 A web-proxy1                web-proxy               system                  active    
[normis@demo.mt.lv] /store> add 
 activate  comment  copy-from  disabled  name  disk  type  

[normis@demo.mt.lv] /store> add name=webproxy_backup disk=disk1 type=web-proxy activate=no

This will add a new storage place for Webproxy on disk1, and will set it as inactive.

Activate new store instance to save proxy cache on secondary disk (other proxy settings configured separately from /ip proxy menu),

[normis@demo.mt.lv] > store activate webproxy-backup

E.g. RB1000 with populated CF Card slot and User Manager, one can add the CF card for use by User manager to store all it's data as follows

/store add disk=CF1 type=user-manager activate=yes