modified on 7 sty 2010 at 08:29 ••• 5 963 views

Styl Cisco VPLS

Z MikroTik Wiki

Spis treści

Wprowadzenie

Począwszy od wersji 3.20 RouterOS ma zaimplementowaną usługę zapewniającą kompatybilność z VPLS firmy Cisco:

  • Statyczne speudołącza VPLS stylu Cisco (RFC 4447 FEC typ 0x80)
  • Oparte o BGP autowykrywanie Cisco VPLS (draft-ietf-l2vpn-signaling-08)

Podczas sygnalizacji statycznych tuneli VPLs (pseudołącz) z użyciem LDP, Cisco nie używa indentyfikacji końca pseudołacza, jak przewiduje RFC 4762 (FEC typ 0.x61), ale używa innej metody - z RFC 4447 (FEC typ 0x80). Takie pseudołacza mogą być konfigurowane w RouterOS poprzez ustawienia cisco-style i cisco-style-id.

Cisco nie implementuje opartym o BGP autowykrywania i sygnalizacji, według RFC 4671. Zamiast tego, Cisco implementuje oparte o BGP autowykrywanie (draft-ietf-l2vpn-signaling-08). Ta metoda używa BGP tylko do wykrywania innych peerów uczestniczących w VPLS. Sygnalizacja pseudołącz VPLS jest realizowana przez LDP.

Ten artykuł skupia się na konfiguracji RouterOS związanej z kompatybilnością z Cisco, ogólne informacje można znaleźć w LDP i VPLS oparty o LDP , informacje o RFC 4671 kompatybilnym z VPLS opartym o BGP zobacz VPLS oparty o BGP.

Przykład sieci

Przykładowa sieć jest taka sama jak w LDP i VPLS oparty o LDP.

Image:VPLS.png

Wymagania klientów A i B są takie same - segmenty ethernetowe muszą być połączone przezroczyście. Biorąc pod uwagę prostotę topologii sieci, dostawca usług zdecydował się użyć R5 jako reflektora trasy bez zapasowego reflektora. Załóżmy, że komutacja MPLS jest skonfigurowana i uruchomiona, jak opisano w LDP i VPLS oparty o LDP, ale nie ustalono jeszcze żadnej konfiguracji VPLS. Pozostała część artykułu porusza zagadnienia związane z kompatybilnością z Cisco VPLS.

Sieci klienta B połączone są przez statyczne pseudołącza VPLS, Sieci klienta A połączone są za pomocą VPLS z autowykrywaniem BGP.

Konfiguracja statycznego interfejsu VPLS w stylu Cisco

Statyczny interfejs VPLS kompatybilny z Cisco tworzone jest poprzez wpisanie odpowiednich parametrów: cisco-style=yes określa, czy interfejs VPLS będzie używać Ciscopodobnej identyfikacji końca tunelu, a parametr cisco-style-id określa IP pseudołącza. Na R1:

[admin@R1] /interface vpls> add disabled=no cisco-style=yes cisco-style-id=666 remote-peer=9.9.9.5

NA R5:

[admin@R5] /interface vpls> add disabled=no cisco-style=yes cisco-style-id=666 remote-peer=9.9.9.1

Powinna zostać zestawiona sesja LDP pomiedzy R1 i R5, a interfejs VPLS powinien stać się aktywny:

[admin@R1] > mpls ldp neighbor print
Flags: X - disabled, D - dynamic, O - operational, T - sending-targeted-hello, V - vpls
 #      TRANSPORT       LOCAL-TRANSPORT PEER                       SEND-TARGETED ADDRESSES
 0 DO   9.9.9.2         9.9.9.1         9.9.9.2:0                  no            1.1.1.2
                                                                                 2.2.2.2
                                                                                 9.9.9.2
 1 DOTV 9.9.9.5         9.9.9.1         9.9.9.5:0                  yes           4.4.4.5
                                                                                 5.5.5.5
                                                                                 9.9.9.5
[admin@R1] > /interface vpls print
Flags: X - disabled, R - running, D - dynamic, B - bgp-signaled, C - cisco-bgp-signaled
 0 R   name="vpls1" mtu=1500 mac-address=02:94:02:DB:60:6E arp=enabled disable-running-check=no
remote-peer=9.9.9.5 cisco-style=yes cisco-style-id=666
[admin@R1] > /interface vpls monitor vpls1 once
       remote-label: 29
        local-label: 31
      remote-status:
          transport: 9.9.9.5/32
  transport-nexthop: 1.1.1.2
     imposed-labels: 24,29

Pozostała część konfiguracji jest taka sama jak opisana w LDP i VPLS oparty o LDP

Konfiguracja BGP dla kompatybilnego z Cisco VPLS

Konfiguracja kompatybilnej z Cisco instancji BGP powoduje, że router rozgłasza VPLS NLRI według draft-ietf-l2vpn-signaling-08. Należy zauważyć, że NLRI używa takich samych wartości BGP AFI/SAFI jak RFC 4762 kompatybilne z BGP VPLS. Z tego powodu tylko jedna specyfikacja (skonfigurowana jako peer BGP address-families) powinna być obsługiwana na raz.

Aby uniknąć konfiguracji całej siatki sesji BGP pomiędzy routerami pracującymi jako punkty podłączenia sieci klienta A (R1, R4, R5), R5 zostanie użyty jako reflektor trasy - tak samo jak w VPLS oparty o BGP.

Na R5, upewnij się ze włączona jest funkcja client-to-client-reflection:

[admin@R5] /routing bgp instance> pr
Flags: X - disabled
 0   name="default" as=65530 router-id=0.0.0.0 redistribute-connected=no redistribute-static=no redistribute-rip=no
     redistribute-ospf=no redistribute-other-bgp=no out-filter="" client-to-client-reflection=yes ignore-as-path-len=no

Utwórzmy peerów BGP ze wsparciem l2vpn-cisco w address-families peerów, na R5 skonfigurujmy reflektor trasy:

[admin@R5] /routing bgp peer> add remote-as=65530 update-source=lobridge instance=default remote-address=9.9.9.1
address-families=l2vpn-cisco route-reflect=yes
[admin@R5] /routing bgp peer> add remote-as=65530 update-source=lobridge instance=default remote-address=9.9.9.4
address-families=l2vpn-cisco route-reflect=yes
[admin@R1] /routing bgp peer> add remote-as=65530 update-source=lobridge instance=default remote-address=9.9.9.5
address-families=l2vpn-cisco
[admin@R4] /routing bgp peer> add remote-as=65530 update-source=lobridge instance=default remote-address=9.9.9.5
address-families=l2vpn-cisco

Konfiguracjia instancji BGP VPLS kompatybilnej z Cisco

W celu zestawienia całej sieci pseudołączy VPLS, należy utworzyć odpowiednie instancje VPLS kompatybilne z Cisco. Tworzenie instancji powodujących wstrzykiwanie VPLS BGP NLRI w sieci BGP:

[admin@R1] /interface vpls cisco-bgp-vpls> add bridge=A bridge-horizon=1 export-route-targets=1:1 import-route-targets=1:1
l2router-id=9.9.9.1 route-distinguisher=1:1 vpls-id=1:1
[admin@R4] /interface vpls cisco-bgp-vpls> add bridge=A bridge-horizon=1 export-route-targets=1:1 import-route-targets=1:1
l2router-id=9.9.9.4 route-distinguisher=1:1 vpls-id=1:1
[admin@R5] /interface vpls cisco-bgp-vpls> add bridge=A bridge-horizon=1 export-route-targets=1:1 import-route-targets=1:1
l2router-id=9.9.9.5 route-distinguisher=1:1 vpls-id=1:1

Powoduje to, że zostaje zestawiona cała sieć sesji LDP oraz odpowiednie interfejsy VPLS, np na R4:

[admin@R4] > /mpls ldp neighbor print
Flags: X - disabled, D - dynamic, O - operational, T - sending-targeted-hello, V - vpls
 ...
 1 DOTV 9.9.9.5         9.9.9.4         9.9.9.5:0                  no            4.4.4.5
                                                                                 5.5.5.5
                                                                                 9.9.9.5
 2 DOTV 9.9.9.1         9.9.9.4         9.9.9.1:0                  yes           1.1.1.1
                                                                                 9.9.9.1
[admin@R4] > /interface vpls print
Flags: X - disabled, R - running, D - dynamic, B - bgp-signaled, C - cisco-bgp-signaled
 0 RDC name="vpls1" mtu=1500 mac-address=02:62:65:24:4C:FD arp=enabled disable-running-check=no remote-peer=9.9.9.1
       vpls-id=1:1 cisco-style=no cisco-style-id=0 vpls=cisco-bgp-vpls1

 1 RDC name="vpls2" mtu=1500 mac-address=02:58:9F:80:EB:94 arp=enabled disable-running-check=no remote-peer=9.9.9.5
       vpls-id=1:1 cisco-style=no cisco-style-id=0 vpls=cisco-bgp-vpls1

Zobacz również

LDP i VPLS oparty o LDP