modified on 21 lip 2010 at 09:49 ••• 15 874 views

System/Czas

Z MikroTik Wiki

Spis treści

Zegar Systemowy

Wprowadzenie

Zegar systemowy pozwala routerowi na śledzenie aktualnej daty o czasu.

Specyfikacja

Wymagana licencja: Level1

Poziom menu: '/system clock

Opis Własności

date (text) - data w formacie "mm/DD/RRR"

gmt-offset (read-only: text) - strefa czasowa UTC w formacie "+HH:MM" lub "-HH:MM"

time (time) - czas w formacie "HH:MM:SS"

time-zone-name (text; default: manual) - nazwa strefy czasowej (zazwyczaj, identyfikowanej przez główne miasto lub państwo). Przesunięcie UTC i informacja DST wybranej lokalizacji

  • manual - przesunięcie UTC i aktywacja DST ustawiane jest ręcznie

Uwagi

Zalecany jest restart routera po zmianie czasu, aby wyeleminować możliwe błędy w pomiarze czasu i logów systemowych.

Ustawienia daty i czasu stają się pernamentne i wpływają na ustawienia BIOSu.

Jeżeli aktualizacja NTP przesuwa czas o jedną godzine, pomimo, że strefa czasowa jest ustawiona poprawnie, możliwe, że trzeba poprawić ustawienie DST w menu /system clock manual

Przykład

Aby wyświetlić ustawienia aktualnej daty i czasu:

[admin@Local] system clock> print
            time: 09:08:37
            date: nov/18/2007
  time-zone-name: "manual"
      gmt-offset: +00:00
[admin@Local] system clock>

Aby ustawić datę i czas na EET:

[admin@Local] system clock> set date=nov/22/2022 time=11:10:21 time-zone-name=EET
[admin@Local] system clock> print
        time: 11:10:25
        date: nov/18/2007
  time-zone-name: "EET"
      gmt-offset: +02:00
[admin@Local] system clock>

Ręczne Ustawienie Strefy Czasowej

Opis

Zazwyczaj strefa czasowa i powiązany z nią czas aktywacji/dezaktywaci DST jest poprawnie skonfigurowany gdy najbliższa główna lokacja jest określona w parametrze time-zone-name. W większości krajów, reżim Daylight Saving Time jest aktywowany na wiosnę i deaktywowany na jesieni. To menu konfiguracyjne zapewnia usługę strefy czasowej UTC i aktywacji/dezaktywacji DST, dostosowane do strefy czasowej w zależności od lokalizacji.

Opis własności

dst-delta (text; default: +01:00) - przesunięcie czasu lokalnej strefy czasowej w formacie "+HH:MM" or "-HH:MM" w czasie okresu trwania DST

dst-end (date time) - czas i data gdy okres DST się kończy

dst-start (date time) - czas i data gdy okres DST się zaczyna

time-zone (text) - przesunięcie względem czasu UTC charakterystyczne dla lokalnej strefy czasowej w formacie "+HH:MM" or "-HH:MM"

Przykład

Dla strefy czasowej EET i zmiany strefy czasowej DST aktywnej od mar/27/2005 03:00:00 to oct/30/2005 03:00:00':

[admin@MikroTik] system clock> set time-zone-name=manual
[admin@MikroTik] system clock> manual set time-zone=+02:00 dst-delta=+01:00 \
\... dst-start="mar/27/2005 03:00:00" dst-end="oct/30/2005 03:00:00"
[admin@MikroTik] system clock> manual print
  time-zone: +02:00
  dst-delta: +01:00
  dst-start: mar/27/2005 03:00:00
    dst-end: oct/30/2005 03:00:00
[admin@MikroTik] system clock dst>

Informacje Ogólne

Specyfikacja

Poziom menu: /system ntp client

Standardy i Technologie:SNTP version 4 (RFC 2030)

Opis

Protokół NTP pozwala na synchronizację czasu wśród komputerów w sieci. Dobrze jest, jeśli dostępne jest połączenie internetowe i lokalny serwer NTP jest synchronizowany z odpowiednim źródłem czasu. SNTP jest uproszczoną wersją NTP, kompatybilną z prawie wszystkimi internetowymi serwerami NTP, ale brakuje w nim kilku wewnętrznych algorytmów wysokiej precyzji (dzięki czemu ma znacznie mniejsze wymagania i mniejsze zużycie pamięci). Istnieje także implementacja klienta i serwera pełnego NTP dla RouterOS dostępna w oddzielnej paczce (paczka ntp dostępna jest do pobrania z www.mikrotik.com) z wyższymi wymaganiami sprzętowymi i większą ilością opcji, ale mały klient SNTP zawarty w paczce system jest wystarczający w większości przypadków. Zauważ, że oprogramowanie zawarte w ntp używa tego samego menu konfiguracyjnego , więc nie musisz używać na raz NTP i SNTP.

Opis własności

active-server (read-only: IP address) - serwer, z którym komunikuje się klient (tylko w trybie unicast)

enabled (yes | no; default: no) - czy klient SNTP jest włączony

last-adjustment (read-only: time) - różnica pomiędzy czasem lokalnym i czasem odebranym podczas ostatniej aktualizacji

last-bad-packet-before (read-only: time) - czas od momentu kiedy odebrano ostatni niepoprawny pakiet NTP

last-bad-packet-from (read-only: IP address) - adres serwera, który wysłał ostatni niepoprawny pakiet

last-bad-packet-reason (read-only: text) - powód, dla którego ostatni niepoprawny pakiet został odrzucony

last-update-before (read-only: time) - czas od ostatniej aktualizacji czasu

last-update-from (read-only: IP address) - adres IP serwera, który wysłał ostatnią przyjętą wiadomość, która zaktualizowała czas

mode (unicast | broadcast; default: broadcast) - tryb klienta NTP

  • broadcast - klient NTP nasłuchuje wiadomości broadcastowych wysłanych przez dowolny serwer NTP. Po otrzymaniu pierwszej wiadomości broadcastowej, klient synchronizuje lokalny zegar używając trybu unicastowego. Później nie wysyła żadnych pakietów do tego serwera NTP, ale czeka na kolejną wiadomość broadcastową
  • unicast - klient NTP łączy się z określonym serwerem NTP. Adres IP serwera NTP musi być ustawiony w wartościach ntp-serwer i/lub second-ntp-server. Najpierw klient synchronizuje się z serwerem TNP, po czym okresowo (64...1024s) wysyła żądania czasu do serwera NTP

poll-interval (read-only: time) - czas pomiędzy wiadomościami wysyłanymi do serwera (tylko w unicast)

primary-ntp (IP address; default: 0.0.0.0) - adres IP głównego serwera NTP

secondary-ntp (IP address; default: 0.0.0.0) - adres IP pomocniczego serwera NTP

Uwagi

UWAGA! Używanie trybu broadcast jest niebezpieczne! Intruz (lub zwykły użytkownik) może postawić swój własny serwer NTP. Jeżeli nowy serwer zostanie wybrany jako źródło dla Twojego routera, będzie istniała możliwość, że ten użytkownik będzie mógł dowolnie zmieniać czas na Twoim routerze.

Przykład

Aby włączyć synchronizację klienta NTP z serwerem 159.148.60.11:

[admin@MikroTik] system ntp client> set enabled=yes primary-ntp=159.148.60.2 \
\... mode=unicast
[admin@MikroTik] system ntp client> print
             enabled: yes
                mode: unicast
         primary-ntp: 159.148.60.11
       secondary-ntp: 0.0.0.0
       poll-interval: 8m32s
       active-server: 159.148.60.11
    last-update-from: 159.148.60.11
  last-update-before: 1m38s120ms
     last-adjustment: 2ms562us
[admin@MikroTik] system ntp client>