modified on 21 lip 2010 at 09:22 ••• 5 320 views

Tworzenie adresu pętli zwrotnej IPv6

Z MikroTik Wiki

W niektórych przypadkach wymagane jest posiadanie interfejsu pętli zwrotnej (loopback). Może być używany do przechowywania adresów należących do samego routera ale nie dla konkretnego wychodzącego interfejsu. Takie adresy są przydatne, na przykład, jako adres źródłowy dla połączeń TCP pomiędzy dwoma routerami, które mają więcej niż jeden fizyczny interfejs pomiędzy sobą.

Zalecanym sposobem dodania interfejsu pętli zwrotnej dla IPv4 w MT RouterOS jest stworzenie nowego pustego interfejsu mostkowego:

/interface bridge add name=lobridge
# loopback address
/ip address add address=10.0.0.1/24 interface=lobridge

Dla IPv6 to rozwiązanie nie będzie działać.

Pusty interfejs mostkowy domyślnie ma zerowy adres MAC. Routeróś nie generuje adresu link-local IPv6 dla interfejsów z zerowym adresem MAC (z powodów możliwości wystąpienia kolizji adresu wyższej warstwy).

Ponieważ adres IPv6 link-local jest wymagany aby IPv6 działał poprawnie na interfejsie, to zazwyczaj pusty interfejs mostkowy nie może być używany jako interfejs pętli zwrotnej z IPv6.

Zalecane Rozwiązanie

Dodaj pusty mostek i określ ręcznie adres MAC mostka:

/interface bridge add name=lobridge auto-mac=no admin-mac=01:00:00:00:01:00
# adres loopback
/ipv6 address add address=2003::1/64 advertise=no interface=lobridge

Alternatywnym rozwiązaniem jest użycie interfejsu fałszywego tunelu EoIP zamiast mostka. Zostanie wtedy wygenerowany losowy adres MAC.

Wyniki

Sprawdź, czy jesteś w stanie pingować adres pętli zwrotnej:

/ping 2003::1
2003::1 64 byte ping: ttl=64 time=5 ms
2003::1 64 byte ping: ttl=64 time=5 ms