modified on 1 lip 2010 at 11:24 ••• 12 580 views

UPnP

Z MikroTik Wiki

Spis treści

Informacje Ogólne

Wprowadzenie

MikroTik RouterOS obsługuje architekturę Universal Plug and Play dla przezroczystego połączenia w sieci peer-to-peer komputerów osobistych i sieciowych inteligentnych urządzeń. UPnP zapewnia możliwość automatycznego łączenia tych urządzeń ze sobą i umożliwiając stworzenie sieci dla wielu osób.

Specyfikacja

Wymagany pakiet: system

Wymagana licencja: Level1

Poziom menu: /ip upnp

Standardy i technologie: TCP/IP, HTTP, XML, IGD

Wykorzystanie sprzętu: brak

Opis

UPnP pozwala na komunikację między dwoma urządzeniami pod kontrolą dowolnego urządzenia kontrolującego w sieci. UPnP jest całkowicie niezależny od każdego medium fizycznego. Obsługuje sieci z automatycznym wykrywaniem bez konfiguracji inicjalizacyjnej, za pomocą którego urządzenie może być dynamicznie podłączane do sieci. Serwery DHCP i DNS są opcjonalne i będą używane, jeżeli będą obecne w sieci. UPnP implementuje proste ale wystarczająco dobre NAT, które pozwala klientowi uzyskać pełną obsługę dwukierunkowego połączenia peer-to-peer zza NAT'u.

Występują dwa typy interfejsów dal UPnP: wewnętrzny ( ten, do którego podłączeni są klineci) i zewnętrzny (ten, do którego podłączony jest internet). Router może mieć tylko jeden zewnętrzny interfejs z adresem 'publicznym' i tak dużo interfejsów wewnętrznych ile jest potrzebne, wszystkie z 'wewnętrznymi' adresami IP z źródłowym NAT'em.

Protokół UPnP używany jest przez wiele nowoczesnych aplikacji, jak większość gier DirectX, jak również wiele usług Windows Messenger za firewallem.

Dodatkowe Informacje

Forum UPnP

Włączanie Universal Plug-n-Play

Poziom menu: /ip upnp

Opis własności

allow-disable-external-interface (yes | no; default: yes) - określa, czy użytkownicy mogą wyłączyć zewnętrzny interfejs routera. Ta funkcjonalność (aby użytkownicy mieli możliwość wyłączać zewnętrzny interfejs bez procedury uwierzytelniania) standardowo jest włączona, ale czasami możesz wyłączyć tą usługę.

enabled (yes | no; default: no) - czy usługa UPnP jest włączona

show-dummy-rule (yes | no; default: yes) - ta opcja włącza rozwiązanie prowizoryczne dla niektórych uszkodzonych rozwiązań, które niepoprawnie obsługują reguły UPnP (na przykład, wyskakują wiadomości o błędzie). Ta opcja informuje serwer aby zainstalował 'udawaną' (bezcelową) regułę UPnp, która jest obserwowana przez klientów, która odmawia poprawnego działania.

Uwagi

UWAGA: jeżeli nie wyłączysz allow-disable-external-interface, dowolny użtrtkownik z sieci lokalnej może (bez żadnej procedury uwierzytelniającej) wyłączyć zewnętrzny interfejs routera.

Przykład

Aby włączyć usługę UPnP:

[admin@MikroTik] ip upnp> set enable=yes
[admin@MikroTik] ip upnp> print
                             enabled: yes
    allow-disable-external-interface: yes
                     show-dummy-rule: yes
[admin@MikroTik] ip upnp>

Interfejsy UPnP

Poziom menu: /ip upnp interfaces

Opis własności

interface (name) -nazwa interfesju na którym działa UPnP

type (external | internal) - typ interfejsu, któryś z:

  • external - interfejs z przydzielonym mu globalnym adresem IP
  • internal - lokalny interfejs routera, z którym łączą się klienci


Uwagi

Rekomendowane jest zaktualizowanie bibliotek DirectX runtime do wersji DirectX 9.0C lub wyższej i Windows Messenger'a do wersji 5.0 lub wyższej aby UPnP działało poprawnie.

Przykład

Grafika:upnp-1.jpg

Mamy już włączoną maskaradę na naszym routerze:

[admin@MikroTik] ip upnp interfaces> /ip firewall src-nat print
Flags: X - disabled, I - invalid, D - dynamic
  0   chain=srcnat action=masquerade out-interface=ether1
[admin@MikroTik] ip upnp interfaces>

Teraz musimy dodać interfejsy i włączyć UPnP:

[admin@MikroTik] ip upnp interfaces> add interface=ether1 type=external
[admin@MikroTik] ip upnp interfaces> add interface=ether2 type=internal
[admin@MikroTik] ip upnp interfaces> print
Flags: X - disabled
  #   INTERFACE TYPE
  0 X ether1    external
  1 X ether2    internal

[admin@MikroTik] ip upnp interfaces> enable 0,1
[admin@MikroTik] ip upnp interfaces> .. set enabled=yes
[admin@MikroTik] ip upnp interfaces>